3 Replies Latest reply on Mar 2, 2014 10:07 AM by PeFe_666001

    Kinetis K60 Support??  Shown on FAQ

      Hello,

       

        I have recently seen that on the WICED WIFI FAQ it shows that the K60 Series of MCUs is now supported by the SDK?  I was not aware of this, is this new?  Does the SDK officially support the K60 series?  I have recently seen several customers that would like this so it is of very significant importance.  Can someone please fill me in on the details here?

       

       

      Regards,

       

      Frank
        • 1. Re: Kinetis K60 Support??  Shown on FAQ
          K60 support was in 2.3.1.

           

          We are currently working on adding support for a broadcom designed WICED module with a K60.

           

          The original platform was based on a hacked up Freescale tower board.
          • 2. Re: Kinetis K60 Support??  Shown on FAQ
            K60 support was in 2.3.1.

             

            We are currently working on adding support for a broadcom designed WICED module with a K60.

             

            The original platform was based on a hacked up Freescale tower board.

             

             

            That is excellent news Jason!!  I was not fully aware of that...Thanks Frank
            • 3. Re: Re: Kinetis K60 Support??  Shown on FAQ
              PeFe_666001

              I am using a seperate tool (CodeWarrior Flash Programmer) to program the K60 MCU on the TWRK60D100M board

              There appears to be an issue with the ELF file generated. On examining the ELF file I note the MCUs flash is erased and programmed from an offset of 8000 onwards, ie. the Vector table,etc at 0x00000 is not getting programmed?!

               

              For comparison and analysis I have attached the following files:
              snip_ping_webserver-TWRK60D100M.elf

              hello_world.elf  (to illustrate expected Cortex-M4 / K60 flash programming)

              snip.ping_webserver-TWRK60D100M_console_log.txt

               

              It appears additional programming of the region from 0x00000 to 0x08000 is required?

               

              Procedure used to build ELF file was to run snip.ping_webserver-TWRK60D100M

              WICED SDK version is 2.4.0

              I have attached the console output from this build

               

              Any help / insights in this regard would be welcome... :-)

               

              Thanks

              Peter Fenn

               

              PS: When can we expect support for mentioned "Broadcom-designed WICED module with a K60" ?

              • 4. Re: Re: Kinetis K60 Support??  Shown on FAQ
                PeFe_666001

                Ok, have figured-out the flash programming issue: Not obvious from the documentation but BOOTLOADER and DCT elf files needed to be separately programmed to the K60 MCU's flash memory.

                ie.

                0x00000 waf_bootloader-NoOS-NoNS-TWRK60D100M-SPI.elf

                0x04000 DCT.elf

                0x08000 snip_ping_webserver-TWRK60D100M.elf

                 

                The app now gets as far as SPI interface initialization according to my console screen:

                Platform TWRK60D100M initialised

                Started ThreadX v5.5

                Initialising NetX v5.6

                Creating Packet pools

                Starting Wiced v2.4.0

                WWD SPI interface initialised

                 

                Now checking network settings,etc...

                Peter