2 Replies Latest reply on Jan 17, 2017 6:38 AM by userc_38501

    UAC Example with 16kHZ not working in Linux

      Hi,

         

      I tried to run the UAC example in Linux (Ubuntu 16.04). This example, which streams audio from SPI flash at a rate of 48kHz sampling works fine. I modified the descriptor file for 16kHZ sampling rate and re-compiled it and it failed to work.

         

      I am using Audacity in Linux to start streaming.

         

      I have attached the whole folder of the example.

        • 1. Re: UAC Example with 16kHZ not working in Linux

          Please add the following changes and test:

             

          1) sampling frequency in audio format descriptor :     0x80, 0x3E, 0x00, 

             

          2) Transaction size in Endpoint descriptor for ISO streaming Audio data 0x20, 0x00,

             

          3) Bytes per interval in  Super speed endpoint companion descriptor:   0x20, 0x00, 

             

          4) in the cyfxuac.c file, change the macro definition to: CY_FX3_ISO_XFER_LEN                             (32)

          • 2. Re: UAC Example with 16kHZ not working in Linux

            Hi Nishant,

               

            We tried the change you suggested. With this, the streaming happens. But, the sample rate is wrong which means when we play back the same recorded samples at 16kHZ, it is not like original audio. Will the ISO packet length (here 32) affect the rate of capturing ?