10 Replies Latest reply on May 20, 2015 5:03 AM by userc_18463

    Why snip.email send failed?

      Hi,

       

      I use WICED-SDK-2.3.1, download snip.email into BCM9WCDPLUS114, then I can see this:

       

       

      Successfully retrieved SMTP server IP : 123.125.50.135

       

      Sending email ... FAILED!

       

       

      RECIPIENT is my private email account and I can guarantee that its available.

       

      Why sending email...FAILED!

       

       

      Kaiser
        • 1. Re: Why snip.email send failed?
          ShawnA_01
          I see a similar failure when using SDK 2.4.0-RC1:

           

           

          Platform BCM943362WCD4 initialised

           

          Started ThreadX v5.5

           

          Initialising NetX v5.6

           

          Creating Packet pools

           

          Starting Wiced v2.4.0-RC1

           

          Joining : CaseyBabyBG

           

          Successfully joined : CaseyBabyBG

           

          Obtaining IPv4 address via DHCP

           

          Setting IPv6 link-local address

           

          IPv4 network ready IP: 192.168.1.15

           

          Getting NTP time... success

           

          Current time is: 2013-11-07T18:43:11.142000

           

          Querying DNS server for smtp.gmail.com

           

          Successfully retrieved SMTP server IP : 74.125.142.108

           

          Sending email ... FAILED!

           

           

          And I, like you - have a functioning email account used in the #define RECIPIENT

           

           

          Lastly, I can PING the gmail server from my machine....

           

          =========================================

           

          C:Userssantol>ping smtp.gmail.com

           

          Pinging gmail-smtp-msa.l.google.com [74.125.142.108] with 32 bytes of data:

           

          Reply from 74.125.142.108: bytes=32 time=156ms TTL=41

           

          Reply from 74.125.142.108: bytes=32 time=147ms TTL=41

           

          Reply from 74.125.142.108: bytes=32 time=146ms TTL=41

           

          Reply from 74.125.142.108: bytes=32 time=157ms TTL=41

           

           

          We need to understand why wiced_smtp_send() is not returning WICED_SUCCESS.  Since there are lower level function calls within wiced_smtp_send() that can cause this problem, we need to single step to identify which routine is not happy.
          • 2. Re: Why snip.email send failed?
            Neither of you posted a wirelesss wireshark packet capture so

             

            we have no way to help you debug what is going wrong.
            • 3. Re: Why snip.email send failed?
              @santol : did you use the WICED email address?

               

              Google has recently blocked it I have just learned.

               

              Try using your own email username/password.
              • 4. Re: Why snip.email send failed?
                ShawnA_01
                I am traveling this week, but will provide the WireShark capture.

                 

                 

                I was using my personal gmail address, but will also test with my corporate address and report back.
                • 5. Re: Why snip.email send failed?
                  I just tested the email snippet works using SDK-2.4.0.

                   

                  I sent an email from my gmail address to my yahoo address.

                   

                  Worked first go.

                   

                   

                  Dont forget to change both the recipient and the sender as shown below.

                   

                   

                      
                  #define RECIPIENT     "myyahooname@yahoo.com"
                  

                   

                   

                      
                  account.email_address     = "mygmailname@gmail.com";  /* or use your email account    */
                  account.user_name         = "mygmailname";            /* or use your username         */
                  account.password          = "XXXXXX";                 /* or use your password         */
                  

                   

                   

                  If this still doesnt work for you with 2.4.0, please post a wireless trace and provide the SSID/passphrase for the AP if your AP uses encryption.
                  • 6. Re: Why snip.email send failed?
                    ShawnA_01
                    snip.email does work when changing the login credentials of the sender to my personal information - Thank You.

                     

                     

                    Ironically, I spent more time academically exploring the code with the debugger than trying something simple like changing the senders information.  That is what I get for being a lemming and following the simple (now out of date) instructions at the top of email.c.....   Thanks again.
                    • 7. Re: Why snip.email send failed?
                      Great you got it to work!

                       

                      Why do you think the instructions are out of date?

                       

                      The only issue that may have occurred here is that google blocked the WICED email address from sending email.

                       

                      Ill add a further note in the instructions about this.
                      • 8. Re: Why snip.email send failed?
                        ShawnA_01
                        The instructions at the top of the C file clearly state we must modify #define RECIPIENT.  Its only deeper in that we learned we must also modify send_email() routine to use our personal gmail credentials as well.

                         

                         

                        I had falsely assumed the (Broadcom) credentials for the sender worked and didnt even think to put my personal credentials in its place; especially since the send_mail() routine states "or use your", as opposed to "you must use your" vernacular.

                         

                         

                        It may help other users if they were told to not only change #RECIPIENT, but also to put their personal gmail credentials into send_mail().
                        • 9. Re: Why snip.email send failed?
                          I updated the app instructions immediately after my last post.

                           

                          The updated instructions will appear in the next SDK release:

                           

                          /** @file
                           *
                           * SMTP e-mail Application
                           *
                           * This application demonstrates how to use the WICED SMTP API
                           * to send a secure email.
                           *
                           * Features demonstrated
                           * - Wi-Fi client
                           * - SNTP time synchronisation
                           * - DNS lookup
                           * - SMTP (email) send
                           *
                           * Application Instructions
                           * 1. Modify the CLIENT_AP_SSID/CLIENT_AP_PASSPHRASE Wi-Fi credentials
                           *    in the wifi_config_dct.h header file to match your Wi-Fi access point
                           * 2. Change the #define RECIPIENT email address to match your email address
                           * 3. If desired, change the email account used to send email (or use
                           *    the default wiced.test@gmail.com account)
                           * 4. Connect a PC terminal to the serial port of the WICED Eval board,
                           *    then build and download the application as described in the WICED
                           *    Quick Start Guide
                           *
                           * After the download completes, the application :
                           *  - Connects to the Wi-Fi network specified
                           *  - Updates the local time from the network using the SNTP library
                           *  - Attempts to send an email to the RECIPIENT email address and
                           *    prints the result to the terminal
                           *  - Shuts down
                           *
                           * IMPORTANT NOTE
                           *   The username/password of the wiced.test@gmail.com email account used
                           *   in this application is provided in good faith to enable demonstration
                           *   of the WICED SMTP API. Please *DO NOT* use the email address in a
                           *   malicious way or use the email address to send unsolicited SPAM email
                           *   to others. Thankyou.
                           *
                           *   Google occasionally blocks the WICED email account used to send email,
                           *   it may be necessary to specify your own email account as noted in point
                           *   (3) above.
                           *
                           */
                          • 10. Re: Why snip.email send failed?

                            Hi,

                                     We are also facing the same problem with snip.email. The only difference between your case and us is,we are using sdk 3.1.2. You have posted your query long back, I think you may got the solution by now. So please help us to solve the issue. we did what ever required changes are needed like changing the sender and receipt emails to our personal mail ids and also tried by changing the port number to different ones(i.e.465,25). Here is the output :

                            @ @@@@

                            Starting WICED v3.1.2

                            Platform BCM9WCDPLUS114 initialised

                            Started ThreadX v5.6

                            Initialising NetX_Duo v5.7_sp1

                            Creating Packet pools

                            WWD SDIO interface initialised

                            WLAN MAC Address : FC:4D:D4:FF:C3:B4

                            WLAN Firmware    : wl0: Nov  7 2014 16:03:45 version 5.90.230.12 FWID 01-cf14784f

                            Joining : Connectify-maanya

                            Successfully joined : Connectify-maanya

                            Obtaining IPv4 address via DHCP

                            Setting IPv6 link-local address

                            IPv4 network ready IP: 192.168.53.101

                            Getting NTP time... success

                            Current time is: 2015-05-19T07:10:41.058712

                            Querying DNS server for smtp.mail.yahoo.com

                            Successfully retrieved SMTP server IP : 106.10.150.171

                            Sending email ... FAILED!