6 Replies Latest reply on Apr 15, 2014 1:32 PM by ZhaohuaS_76

    OpenOCD problem

      Hi,

       

      I am trying to evaluate the Murata module SN8200 by using the evaluation board  SN8200EVK+. I have been able to use the SNICMonitor to read the temperature and configure the module to connect to our WiFi. Since we are planing to put our code in the module, to avoid using an extra MCU, I need to use JTAG to debug the code.

       

       

      I have not been able to connect to the module through the Wiced-SDK, I get the error:

       

       

      Downloading Bootloader ...
      
      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"
      
      Downloading Application ...
      
      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"
      
      Downloading DCT ...
      
      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

       

       

      I think that I have gotten all the drivers right, this is how it looks like in my device manager and the result from TestLibUsb.exe.

       

      [ATTACH=CONFIG]170[/ATTACH]

       

       

      Any ideas what I am doing wrong?

       

       

      Is there a way the verify that OpenOCD is intsalled/working correctly?

       

       

      Thank you,

       

      Per D

        • 1. Re: OpenOCD problem
          Please uninstall all of the Sychip drivers you installed for the SN8xxx.

           

          Then install the WICED divers. This should fix your problem.

           

           

          Hi,

           

          I am trying to evaluate the Murata module SN8200 by using the evaluation board  SN8200EVK+. I have been able to use the SNICMonitor to read the temperature and configure the module to connect to our WiFi. Since we are planing to put our code in the module, to avoid using an extra MCU, I need to use JTAG to debug the code.

           

           

          I have not been able to connect to the module through the Wiced-SDK, I get the error:

           

           

          Downloading Bootloader ...
          "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"
          Downloading Application ...
          "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"
          Downloading DCT ...
          "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

           

           

          I think that I have gotten all the drivers right, this is how it looks like in my device manager and the result from TestLibUsb.exe.

           

          [ATTACH=CONFIG]170[/ATTACH]

           

           

          Any ideas what I am doing wrong?

           

           

          Is there a way the verify that OpenOCD is intsalled/working correctly?

           

           

          Thank you,

           

          Per D
          • 2. Re: OpenOCD problem

            In the build directory there should be a file called "openocd_log.txt". That will contain the output of OpenOCD and will help us debug the problem you are having.

            Please upload it.

            • 3. Re: OpenOCD problem

              of topic but have you got a example project from murata to work with? I want to do the same.

              • 4. Re: OpenOCD problem

                Another point to note is that in some circumstances the OpenOCD executable is not stopped and retains control of the JTAG device preventing you from downloading a new image or starting a debug session.

                To fix this you should start the task manager and look for any running processes called "openocd-all-brcm-libftdi.exe" and end them.

                 

                As a side note, a debug session is a process called "arm-none-eabi-gdb.exe"

                • 5. Re: OpenOCD problem

                  Hello, I'm new to the group and am setting up the system on Windows 8.1. When I tried to use the OpenOCD programmer I had on my shelf, and it filed in a similar way, I came here and found a few unresolved posts like this one.

                   

                  I suspected that the issue was the "unsigned drivers not supported under Windows 8 issue", so I restarted using the "advanced troubleshooting mode - support unsigned drivers voodoo".

                   

                  It turns out that was not enough. I also had to download a set of OpenOCD drivers for my programmer (which also were unsigned).

                   

                  ... all better now.

                  • 6. Re: Re: OpenOCD problem
                    ZhaohuaS_76

                    Hi Nikvh,

                    I also occurred the OpenOCD failed when downloading bootloader, attached the content of the opencod_log.txt, could you help to check why?

                            Open On-Chip Debugger 0.8.0-dev-00139-g4dfe8d5-dirty (2013-08-22-12:22)

                    Licensed under GNU GPL v2

                    For bug reports, read

                    http://openocd.sourceforge.net/doc/doxygen/bugs.html

                    Info : only one transport option; autoselect 'jtag'

                    trst_and_srst separate srst_nogate trst_push_pull srst_push_pull connect_assert_srst

                    adapter speed: 1000 kHz

                    adapter_nsrst_delay: 100

                    jtag_ntrst_delay: 100

                    Warn : target name is deprecated use: 'cortex_m'

                    jtag_init

                    Info : max TCK change to: 30000 kHz

                    Info : clock speed 1000 kHz

                    Polling target stm32f2xxx.cpu failed, GDB will be halted. Polling again in 100ms

                    Error: JTAG scan chain interrogation failed: all ones

                    Error: Check JTAG interface, timings, target power, etc.

                    Error: Trying to use configured scan chain anyway...

                    Error: stm32f2xxx.cpu: IR capture error; saw 0x0f not 0x01

                    Warn : Bypassing JTAG setup events due to errors

                    Info : Selecting JTAG transport command set.

                    Warn : Invalid ACK 0x7 in JTAG-DP transaction

                    in procedure 'transport'

                    Runtime Error: ./tools/OpenOCD/stm32f2x-flash-app.cfg:10:

                    in procedure 'script'

                    at file "embedded:startup.tcl", line 58

                    in procedure 'init' called at file "./tools/OpenOCD/stm32f2x-flash-app.cfg", line 10