5 Replies Latest reply on Feb 5, 2017 12:36 PM by xezl_2081931

    Problem with CY8CKIT-048 power supply

    xezl_2081931

      The factory soldered 3.3V and 5V pin does not provide power at all. If I don't connect anything to these pins I can measure 5V, but if I connect them as a power supply to any circuit the voltage drops to 0V. The other, unsoldered 3.3/5V and the VDD pins are all right, but I can't figure out why the factory soldered pins doesn't work. I worked around it by using the other pins, but it is quite annoying. This is the case when I use USB power supply.

         

      I also have another power supply problem: If I try to power it from a 12V DC power source through the VIN connections, it just doesn't work. PWRLED flashes for a moment and that's it. SW4 is set to REG, J9's connection is 1-2. If I measure the VDD pin's voltage it's about 0.8V and I can measure ~4.5V on the 5V pins, but if I connect anything to them their voltage drops to 0. I measure 0V on the 3.3V pins.

         

      Am I missing something? What is causing these problems and how can I solve them?

        • 1. Re: Problem with CY8CKIT-048 power supply
          user_242978793

          Those pins are for use for on board devices.  The  voltage regulator U2 can't supply extra power for your other circuits. What kind of 12 Volt supply are you using? So did you say that it works when you use the USB power? Please provide a schematic of your power hookups. The NCP1117DTARKG regulator can only Provide 1 amp total . Check out the Data sheet

          • 2. Re: Problem with CY8CKIT-048 power supply
            xezl_2081931

            Yes it works if I power it through USB. I developed a simple application using a cheap microphone module, a 5K potentiometer and the PIR sensor as sensors and I drive a TIP120 transistor with one of the GPIO-s. The TIP120 controls an LED strip and it uses the 12V power supply. The power supply (noname) can provide 12V@2A.

               

            Until now I used it only to power the ~40 cm long LED strip. The code and the circuits are ready, everything works, so I want to remove the USB cable, and use only the 12V power supply, but it doesn't work. The power supply should be more than enough for this project. I connected it to the board through the pins in the green circle on the attached picture. I connected it correctly and I read the 12V between those pins with my multimeter, so it should be ok. I'll provide schematics as soon as I can, but it works with USB and it doesn't work with the 12V supply even if I disconnect my custom circuits, so it shouldn't be a problem.

               

            J9: jumper between 1-2
            SW4 position: REG

            • 3. Re: Problem with CY8CKIT-048 power supply
              user_242978793

              What kind of 12 supply are you using.  It may be the issue it could be over voltage and also the ripple could be high.  Have you tried to use a +12V battery?

              • 4. Re: Problem with CY8CKIT-048 power supply
                xezl_2081931

                I can't give you any specifics on the power supply other than 12V/2A, it's a noname chinese power supply from ebay. I measured the voltage and it's constant 12V so it doesn't seem to be the problem. I can't measure the ripple but I'll give it a try with my quadcopter's LiPo battery on sunday. Until then it's out of my reach.

                • 5. Re: Problem with CY8CKIT-048 power supply
                  xezl_2081931

                  The same thing happened when I used the LiPo battery (charged to 12V only, not 12.6V). No custom circuit connected, Red wire to VIN pin, Black to GND, so it should have worked, but nothing, The VDD voltage varies between 0.3V and 0.9V. 2.5mA current flows through the board so it doesn't indicate that there's any short circuit anywhere. Do you have any idea what could be the problem? Maybe the voltage regulator is malfunctioning? I've never used that before on this board.