3 Replies Latest reply on Mar 8, 2017 5:28 AM by hima

    Error to enable notification

    davidcaraveo54_2033506

      Hello Community, 

         

      I want to write to my server 0x01 to activate the notifications, but when I send the command i got an error: 

         

      CYBLE_ERROR_INVALID_OPERATION

         

      The strange part is when I try to write again, the code works, Im able to to print out the value from the server on my computer via master UART.

         

      I attached the file

         

      thanks David C

        • 1. Re: Error to enable notification
          hima

          Hello,

             

          Can you check at the peripheral side, if the request of enabling the notification is being properly received?

             

          Thanks,

             

          Hima

          • 2. Re: Error to enable notification
            davidcaraveo54_2033506

            Hello Hima, I solved the problem but i have a new one, I need to activate 2 notifications, but the problem is only the first one is activate, I tried to have a  method of each one but I had the same result, only the first method that I call it is which is activated. I wrote code on the second method to be printed via UART and it does, But I do not why the notifications on the server is not activated. 

               

            The handles are corrected and also the peripheral because if I change the order of the methods, the other work but the second not. Futhermore, I have created two variables of CYBLE_GATTC_WRITE_REQ_T. This example I took it from UART_Central of the 100 projects in 100 days.

               

             

               

            CYBLE_GATTC_WRITE_REQ_T enableNotificationReqParamQuat = {
                                                                    {(uint8 *)enableNotificationParam, 2,2},
                                                                    0
                                                                  };

            • 3. Re: Error to enable notification
              hima

              Hello 

                 

              While sending the enable notification packet, is it being received at the server side at the first place? 

                 

              Thanks,

                 

              Hima