1 Reply Latest reply on Mar 14, 2017 10:41 PM by nisa

    running cx3 uvc video project(Cx3UvcOV5640) on windows 10 in high speed mode.

    roman.tcharny_2243706

      Hi,

         

       

         

      I tried to run the cx3 uvc video project(Cx3UvcOV5640) on windows 10 machine in high speed mode(call CyU3PConnectState() with second parameter CyFalse). The device is recognized by windows and Camera application performs streaming but I  get black screen. The super speed mode is working on same machine and both modes are working on linux machine. What can be a reason for such behavior?

         

       

         

      I have another question about linux. We try to run the same projects(high speed and super speed) on windows(8 and 10) under virtualbox on linux.  Should the cx3 work under virtual box? The device in high speed mode is recognized in windows 10 but the capture doesn't work properly - the frame rate is low and i hear the shutter clicks from the device. The super speed device has some problem with descriptors. Here is the output from 'thesycon usb descriptor dumper':

         

       

         

      Information for device USB\Vendor_0000_Product_0000:

         

      Connection Information:
      ------------------------------
      Connection status: Device failed enumeration
      Device actual bus speed: LowSpeed
      Device supports USB 1.1 specification
      Device supports USB 2.0 specification
      Device is hub: No
      Device address: 0x0000
      Current configuration value: 0x00
      Number of open pipes: 0

         

      Microsoft OS Descriptor is not available. Error code: 0x0000001F

         

      String Descriptor Table
      --------------------------------
      Index  LANGID  String
      0x00   0x0000   

         

       

         

      Thanks,

         

      Roman Tcharny

        • 1. Re: running cx3 uvc video project(Cx3UvcOV5640) on windows 10 in high speed mode.
          nisa

          We do not know how Virtualbox might have affected the performance. We check with the DVK on Win 10 and Win8 platform, we notice that it worked fine on both SS and HS mode. Can you once check using the same on a standard Windows platform (without Virtual box?). 

             

          Do you have any other USB/UVC camera? can you check if that works with Virtualbox? Is the Virtualbox hampering with the enumeration? 

             

          Will you be able to share a USB protocol trace recording the enumeration? This will tell us the details on the transactions on the USB bus (we can compare it with standard enumeration steps and see what is different).