2 Replies Latest reply on Jun 20, 2017 5:00 AM by andrie_2270216

    FX3: GPIF II PCLK in Master Sync Mode

    andrie_2270216

      Dear all,

         

      I would like to design an FX3 application with GPIF II in Master Sync Mode. So I took a basic project (SlaveFifoSync) and add some code from the AN87216 (AutoMaster) in ordre to have a master GPIF II interface. I also made a very simple state machine (only 2 states that do nothing and move to each other with no condition with (Logic_One)), but when I try to measure the PCLK with the oscilloscope, the pin is always at 1.

         

      I had the same result when I tried to measure it with the AutoMaster project (AN87216) with no modification.

         

      I initialize the PLL with the function CyFxApplnSetPibDllParameters I found in the AutoMaster project. The DLL seems to be initialized correctly but I have measurable clock (always at 1).

         

      The clock turns to 1 after the API call "CyU3PGpifLoad" and there is no error after the call of "CyU3PGpifSMStart".

         

      Anyone has a clue about why I do not have any signal on the PCLK pin?

         

      Best regards,

         

      Christian

        • 1. Re: FX3: GPIF II PCLK in Master Sync Mode
          nishanta_46

          How many FX3 devices do you have? Is it happening on one chip or multiple chips? Please check with the GPIFtoUSB example and see if you are getting a clock. Please check both, while you receive data using transfer_in in the control center EP0x81. 

             

          C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples\cyfxgpiftousb

             

          Please attach the firmware which you used. I will see if you have made any changes that may cause this.

          • 2. Re: FX3: GPIF II PCLK in Master Sync Mode
            andrie_2270216

            Dear Nishant,

               

            Thank you very much for all your messages!

               

            Sorry, I work in a very small company and I has to manage the PCB outsourcing and putting them into operation, etc. for the last 3 months!!! Now, I have a lot of PCB ready to use in stock and I have time to go back to my USB 3.0 project! :D

               

            About the PCLK clock, it was my fault. The clock was at 192 MHz and I noticed I had the 20 MHz filter enable on my oscilloscope!

               

            I will take some time to go into my project again and I will ask you if I have any question!

               

            Thank you again!

               

            Best regards,

               

            Christian