3 Replies Latest reply on Apr 18, 2018 9:00 AM by e.pratt_1639216

    Cysmart and CY5677 - Unsupported Device

    stephen.whittle

      Here we go again, another query regarding firmware versions for using Cysmart with a new Cy5677 dongle on a Windows 10 x64 machine.

         

      PSOC Programmer initially prompted me to update to Kitprog 2.17, and I've since learned, according to the forums here, that breaks Cysmart, so I've reflashed with C:\Program Files (x86)\Cypress\CY8CKIT-042-BLE Kit\1.0\Firmware\Programmer\KitProg\KitProg.cyacd, and then with the latest Cysmart firmware from the cysmart installation, but I still get Unsupported Device (COM50) in the target selection dialog of Cysmart. 

         

      I'm using the KitProg USB-UART driver. 

         

      I've tested with the upgraded Kitprog 2.17 as well, but no change.

         

      Any suggestions?

         

       

         

      PSOC Programmer output:

         
          

       

          
      Program Finished at 9:35:40 AM                     |                                                     | Programming Succeeded                                                    | Doing Checksum                                                    | Doing Protect                                                    | Verifying of Flash Succeeded...                                                    | Verifying of Flash Starting...                                                    | Programming of Flash Succeeded...                                                    | Programming of Flash Starting...                                                    | Erase Succeeded Device set to CYBL11573-56LQXI at 9:35:15 AM       | 262144  FLASH bytes Device Family set to CY8C4xxx-BLE at 9:35:15 AM    |                                                     | Automatically Detected Device: CYBL11573-56LQXI Program Requested at 9:35:15 AM                    |  Active HEX file set at 9:35:12 AM                  | C:\Program Files (x86)\Cypress\CySmart\1.2\dongle\CY5677\BLE_4_2_Dongle_CySmart_256K.hex                                                    | Please navigate to the Utilities tab and click the Upgrade Firmware button Port Opened with Warnings at 9:34:43 AM            | KitProg version Expecting 2.17, but found 2.14. Opening Port at 9:34:42 AM                         |  Device set to CYBL11573-56LQXI at 9:34:42 AM       | 262144  FLASH bytes Device Family set to CY8C4xxx-BLE at 9:34:41 AM    |  
         
        • 1. Re: Cysmart and CY5677 - Unsupported Device
          anpm

          Hi,

             

          Can you please do the followoing steps to double confirm?

             

          2) Program and update the BLE Dongle firmware. You can find the hex file from the following path

             

          C:\Program Files (x86)\Cypress\CySmart\1.2\dongle\CY5677

             

          3) Open PSoC Programmer (Verify the programmer  version is latest 3.25.0 , if not please download the latest from http://www.cypress.com/documentation/software-and-drivers/psoc-programmer-3245) .

             

          4) Plug the BLE dongle in to PC USB port.

             

          5) In psoc programmer, Select the dongle. Select the hex file of dongle by clicking on the folder button. After that Click on program button. After programming the status will be 'PASS'.

             

          6) Open Utilities tab -> click on upgrade firmware

             

          7) Now close the Programmer and Open Cysmart. Make sure Dongle enumerated successfully. Check whether it is detecting the dongle now or not. (If not, please try press reset button on dongle and check )

             

          If you are still not working, please provide the screenshot.

             

          Also please try with one more PC if possible.

             

           

             

          Thanks,

             

          Anjana

          • 2. Re: Cysmart and CY5677 - Unsupported Device
            jrwagner_2298596

            Hi Anjana,

             

            Do you know what causes the device to go into this Unsupported state? I am currently using the dongle to connect to multiple devices programatically using LabVIEW, and it frequently goes into this unsupported state. If I could figure out what triggers this, it would be extremely helpful!

             

            Thanks,

             

            Jasmine

            • 3. Re: Cysmart and CY5677 - Unsupported Device
              e.pratt_1639216

              It could be the windows drivers with the device being finnicky, but no idea. You could try slowing down how fast you do operations on the dongle and see if the slower speed reduces issues.