3 Replies Latest reply on May 3, 2017 12:24 PM by e.pratt_1639216

    Upgradable-Stack OTA project BLE updated to V3_20 compilation fails






      I'm using the upgradable-stack OTA projects, with environment as:


      PROC module: CYBLE-212019-00


      PSOC Creator 4.0


      Establish projects from the examples: 


      BLE Upgradable Stack Example Launcher &  BLE Upgradable Stack Example Stack in the same workspace.




      Using BLE componet with older version v3_10, both the projects compile successfully!


      If I update the BLE component to v3_20., the BLE Upgradable Stack Example Stack fails with following errors:




      Error in component: cy_boot. The cy_boot_v4_20 component (cy_boot) is not compatible with the selected device. Please check the component datasheet for details on updating to a compatible component


      Error in component: PrISM_1. Component 'PrISM_v2_20' is not supported by the selected device.


      Error in component: PrISM_2. Component 'PrISM_v2_20' is not supported by the selected device.






      Is anyone can help to answer this? 






      Justin Chen