3 Replies Latest reply on May 6, 2017 11:06 PM by user_275930499

    Miniprog3 incorrect PSoC 5 device identified

    user_275930499

      Hi,

         

      We have a design using a CY8C5868AXI-LP035 PSoC 5 which we use for development and has been programmed on many occasions using a Miniprog3 from either PSoC Creator V3.3 or PSoC  Programmer 3.24.2.

         

      However, just from today, whenever we try to program the device it gets wrongly identified by both applications with the message "The selected debug target 'CY8C5667LTI-LP041' is not compatible with the project's selected device 'CY8C5868AXI-LP035'".  It seems to think k that it is a 5667 device which it definitely isn't.

         

      I have tried two different MiniProg3 programmers (one new out of the box) and both give the same result.  I can't simply recompile for the "other" device as it is a completely different package (68pin vs 100pin).

         

      Had anybody come across this problem before?  The PSoC is currently rinning the firmware altready loaded without a problem but I need to resolve the issue to update it.

         

      Many thanks

        • 1. Re: Miniprog3 incorrect PSoC 5 device identified
          user_1377889

          I would try a complete update:

             
                
          • PSoC Creator 4.0 SP1
          •     
          • PSoC Programmer 3.25
          •     
          • Miniprog firmware update using PSoC Programmer
          •     
          • Open a copy of the project in Creator 4.0 and update all components
          •    
             

           

             

          Bob

          • 2. Re: Miniprog3 incorrect PSoC 5 device identified
            user_275930499

            Thanks for the quick suggestions.  I have been avoiding moving to Creator 4 on this project as we had a few issues with USB/PC HID Device version compatibility and boot-loading on a couple of other designs we have "ported" from 3.3.  I guess I can try it on a duplicate of the project without risk especially as we already have another PC with Creator 4 etc.

               

            Is there any logic behind the changes as it has been working fine until now, the PC used for this project has never had Creator 4 on it and the second programmer that we used was a fresh out of the box spare which had never seen any other environment?  All a bit strange but if upgrading everything solves the problem then I'll be very happy!

               

            If this doesn't work, has anybody experienced anything similar and overcome it?

               

            Thanks,

               

            Andy

            • 3. Re: Miniprog3 incorrect PSoC 5 device identified
              user_275930499

              Just to wrap this up, it was a case of "midnight oil fever".  The particular board we were using for testing was one of our "specials" and has two PSoCs on it and we were plugged into the wrong programming header and, guess what, the 2nd processor is a CY8C5667LTI-LP041.  So everything was actually behaving itself correctly except me.  Need to get some more sleep:-)

                 

              Apologies for this curved ball.