2 Replies Latest reply on May 31, 2017 5:05 AM by philipvankampen_2306836

    USBFS - component not found -

    philipvankampen_2306836

      I was working my way through AN-73503, USB HID Bootloader earlier today.  I followed their instructions to delete the default Device Descriptor root.  I then imported the Descriptor Root Bootloader.root.xml.  I continued on in the tutorial, but when I went to compile I had some errors.  I had been messing around with other stuff so I decided to delete the USBFS from the schematic and start again in a new project.  

         

      Now I am all of a sudden unable to call up a USBFS component.  I look in the CyComponentLibrary and it appears to all be there.  I have run an update, a repair and have even uninstalled PSoC Creator and reinstalled it.  But, the same thing: no USBFS.  I have renamed my Cypress folder, installed PSoC creator again and tried to load a USBFS component, but no dice.  

         

      I have noticed that the application seems to know which projects I have worked on recently when I load the newly installed software.  Maybe this is a hint?  I don't know.  

         

      I am unsure where to go from here.  Any help would be much appreciated.  

         

       

         

      Thanks!