6 Replies Latest reply on Sep 4, 2017 10:20 PM by anks

    MiniProg3 not working

    michael.canavan

      Hello,

         

      I am using the CY8CKIT-002 and programming a CYBLE-222005-00 using the  generated hex file and

         

      it is not working.  I know that it worked before for the same model programmer on a different machine.

         

      The setup is the same, perhaps the programmer was connected to the computer before the programmer software

         

      was installed.  (Don't know if this caused the problem or even makes any difference).  Also, both the Programmer Software and the Creator IDE have been re-installed.

         

      I also tried to manually re-register the device as per following instructions:-

         

      CyMiniProg3Service was not properly registered . Please try to do that manually, find it in Programmer folder and register from command line:

         

      c:\Program Files\Cypress\Programmer\Service\CyMiniProg3Service /Service

         

      If it doesn't help then try to unreg and reg it:

         

      c:\Program Files\Cypress\Programmer\3.12\Service\CyMiniProg3Service /unregserver
      c:\Program Files\Cypress\Programmer\3.12\Service\CyMiniProg3Service /Service

         

      The "CyMiniProg3Service.exe" is the executable file of the Service. To register it on the machine you need to run it from command line with "/Service" parameter.
      If you are able to find "./Cypress/Programmer/Service/CyMiniProg3Service.exe" then you can to run register service from command line:

         

      CyMiniProg3Service.exe /Service

         

      This didn't work, 

         

      Please, has anyone experienced this that could point me toward a solution

         

      I'm attaching a screenshot if that helps, and I hope I am in the correct forum....