cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless

tado_4837711
New Contributor II

Hi, there

We plan to use a CYBT-343026-EVAL  as a dual mode bluetooth controller. We have tested the CYBT-343026-EVAL under Linux (using btattach) and Windows(using Cybluetool), it works as expected.

The next step is using a third-party MCU (NUCELO-429ZI STM32F429) working as bluetooth Host connected with CYBT-343026-EVAL through HCI UART

Currently, the Host can send commands (Reset),  unfortunately the CYBT-343026-EVAL gives no response.

We are considering it might caused by the Host Side improper configuration, or the  CYBT-343026-EVAL does not enter the HCI Mode.

So we prefer to add some indicator that the CYBT-343026-EVAL successfully entered the HCI Mode for easy debugging.

Is there any guide to do so?

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator

Sorry, the working mode of the device is hardware related. We can't control the GPIO in HCI mode. 

You may check the HCI mode by sending HCI Reset command. If the device has no response, then the device is not in HCI mode.

View solution in original post

0 Likes
2 Replies
Owen_Zhang123
Moderator
Moderator

Sorry, the working mode of the device is hardware related. We can't control the GPIO in HCI mode. 

You may check the HCI mode by sending HCI Reset command. If the device has no response, then the device is not in HCI mode.

View solution in original post

0 Likes
tado_4837711
New Contributor II

Got it. We have fixed it

0 Likes