cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless

gocchan
New Contributor II

Hi, 

I want to debug a sample code but the following error occurs.

Build and program were succeeded.

gocchan_0-1614147311091.png

gocchan_1-1614148064276.png

 

Could you tell me how to solve it?

HW: CYW920735Q60EVB-01

Debugger: On board (connected to PC via USB)

OS: Windows 10

IDE: Eclipse IDE for ModusToolbox v2.2.0

Sample Code: HID_Dual_Mode_Keyboard

Regards, Gotoda

 

 

0 Likes
1 Solution
gocchan
New Contributor II

Hi,

By referring to the document, I was able to solve the problem by following the steps below.

1) turn off the dip switch (SW9).

2) Set build option by adding ENABLE?=1 in the makefile.

3) Add the following code to the top of main.

        wiced_hal_gpio_select_function(WICED_P02, WICED_SWDCK);

        wiced_hal_gpio_select_function(WICED_P03, WICED_SWDIO);

        wiced_hal_wdog_disable();

        volatile bool cont_process = false;

        uint32_t intrpt = _tx_v7m_get_and_disable_int();

        while(!continue);

        _tx_v7m_set_int(intrpt);

4) Break immediately after starting debugging, set cont_process to true and continue. 

Thank you for teaching me.

Gotoda

 

View solution in original post

3 Replies
DheerajPK_41
Moderator
Moderator

Hi,

May I know which debugger are you using? 

Please check Hardware and Software Requirements in  https://github.com/cypresssemiconductorco/btsdk-docs/blob/master/docs/BT-SDK/WICED-Hardware-Debuggin...

 

Thanks,

-Dheeraj

0 Likes
gocchan
New Contributor II

Hi, 

I use a Segger.

The same error occurs when I add ENABLE_DEBUG?=1 to the makefile.

Regards, Gotoda

 

0 Likes
gocchan
New Contributor II

Hi,

By referring to the document, I was able to solve the problem by following the steps below.

1) turn off the dip switch (SW9).

2) Set build option by adding ENABLE?=1 in the makefile.

3) Add the following code to the top of main.

        wiced_hal_gpio_select_function(WICED_P02, WICED_SWDCK);

        wiced_hal_gpio_select_function(WICED_P03, WICED_SWDIO);

        wiced_hal_wdog_disable();

        volatile bool cont_process = false;

        uint32_t intrpt = _tx_v7m_get_and_disable_int();

        while(!continue);

        _tx_v7m_set_int(intrpt);

4) Break immediately after starting debugging, set cont_process to true and continue. 

Thank you for teaching me.

Gotoda

 

View solution in original post