cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless

cniclaes
New Contributor

Hello,

I see a lot of different information regarding the BT version support:

- Latest datasheet of CYW43438 talk about BT 5.1 but Declaration ID D035240 in the datasheet is for BT 4.2

- Latest datasheet of CYW4343W talk about BT 4.1

- On Bluetooth website, Declaration ID D043208 is 5.1 for CYW43438 and CYW4343W

I suppose the support of BT 5.1 is also related to the firmware loaded, which in turn is related to WICED version used.

Bluetooth search results for WICED shows that:

 - CY-WICED 4.1 BLUETOOTH Host Software Stack is qualified for BT 5.2

- CY-WICED 4.0 BLUETOOTH Host Software Stack is qualified for BT 5.1

Could you tell me, for both chips CYW43438 and CYW4343W, 

- Is there any specific hardware version from which BT 5.1 is supported

- Which minimum version of WICED must be used to support BT 5.1

Thanks!

 

0 Likes
1 Solution
SheetalJ
Moderator
Moderator

Hi @cniclaes ,

I suppose the support of BT 5.1 is also related to the firmware loaded, which in turn is related to WICED version used.

>> Yes you are correct. It depends on the FW which BT version device supports. However, some hardware changes are needed for particular features in BT versions like AoA, AoD & others.

You can use old hardware with latest FW version and avail BT5.1 support.

You can get the version supported by FW using 'get BT version' command. Usually we recommend to use latest WICED/MTB versions as they ahve several feature enhancements & bug fixes,

 

View solution in original post

0 Likes
4 Replies
SheetalJ
Moderator
Moderator

Hi @cniclaes ,

I suppose the support of BT 5.1 is also related to the firmware loaded, which in turn is related to WICED version used.

>> Yes you are correct. It depends on the FW which BT version device supports. However, some hardware changes are needed for particular features in BT versions like AoA, AoD & others.

You can use old hardware with latest FW version and avail BT5.1 support.

You can get the version supported by FW using 'get BT version' command. Usually we recommend to use latest WICED/MTB versions as they ahve several feature enhancements & bug fixes,

 

View solution in original post

0 Likes
cniclaes
New Contributor

Hi,

So could I consider that any design based on CYW4343W or CYW43438 can be BT 5.1 certified if I use the latest firmware as provided with the latest WICED package?

 

 

0 Likes
SheetalJ
Moderator
Moderator

Yes.

0 Likes
cniclaes
New Contributor

Thanks! Very Clear!

0 Likes