cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless

HeGi_2497906
Contributor II

We are using the CYBLE-212006-001 in a project with SPI, we have it set for three slaves, on SS0,SS1,SS2.

I must have missed it in the documentation, but if you want three slaves, number three, which should be SS2, is actually SS3, so in the  function call SPI_SpiSetActiveSlaveSelect(2); if you specify a 2 as shown no SS if fired.  The PIN names, etc are refer to SS2, but regardless it will never work. 

If you specify a 3,  SPI_SpiSetActiveSlaveSelect(3) it works fine; now it makes sense as that is the SS brought out in this module by carefully noticing that there was no SS2 in the pin assignments.

Going back I found no reference to this in the documentation, and the SPI widget did not issue me a warning, this cost us two days to figure out, do you plan to better document this "feature".

Herb

0 Likes
1 Solution
BragadeeshV
Moderator
Moderator

Hi @HeGi_2497906 ,

We regret the inconvenience caused. We will forward your request to the development team to see how this can be corrected. Thank you for your continued interest in Infineon products.

Regards,
Bragadeesh

View solution in original post

0 Likes
1 Reply
BragadeeshV
Moderator
Moderator

Hi @HeGi_2497906 ,

We regret the inconvenience caused. We will forward your request to the development team to see how this can be corrected. Thank you for your continued interest in Infineon products.

Regards,
Bragadeesh

View solution in original post

0 Likes