Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

PaNi_4710066
New Contributor

Hi,

We use AP6212 (BCM43438 based) module on our board and we need wl utility to do compliance testing. Local FAE could provide the wl binary with bcmdhd driver, but we use brcmfmac driver, can anyone help me to provide this? Thanks

Our hardware platform / Env:

- Linux Kernel 4.19, armhf

- Wi-Fi driver: brcmfmac

- Raspberry Pi CM3+ based

 

Best Regards,

Paul

 

0 Likes
1 Solution
raks_99
Moderator
Moderator

Hi Paul,

Sure, Please find the attached zip containing wl tool for 32 and 64-bit arm devices running fmac.

Let me know if it worked for you.

Thanks 

View solution in original post

0 Likes
3 Replies
raks_99
Moderator
Moderator

Hi,

Can you try to get in touch with the module vendor for the wl tool?

If you have issues with that, please do let me know.

Thanks,

0 Likes
PaNi_4710066
New Contributor

@raks_99 

Thank you for your replay. Yes, we have already got in touch with the module vendor. They can only provide the wl tool with bcmdhd driver backend. They don't have wl tool with brcmfmac driver backend. 

We don't want to port the bcmdhd driver again, so could you please build a wl binary for us? Thank you very much.

 

Best Regards,

Paul

0 Likes
raks_99
Moderator
Moderator

Hi Paul,

Sure, Please find the attached zip containing wl tool for 32 and 64-bit arm devices running fmac.

Let me know if it worked for you.

Thanks 

View solution in original post

0 Likes