cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

Anonymous
Not applicable

Hi,

I'm having troubles getting my Ubuntu machine to recognize my BCM9WCD1EVAL1 board. My goal is simple I/O between my evaluation board and the command line of my laptop.

Using my Ubuntu machine I can build and download applications via the WICED SDK make tool.

But when it comes to opening up a serial terminal I can't seem to find the evaluation board.

I just built the snip.stdio application (on my Ubuntu machine), and tested it out on my Windows machine via PuTTY. Works fine.

But when I try to access it via minicom, e.g.

minicom -D /dev/ttyUSB1

I get an error stating that the file is not found. I've checked the contents of /dev before and after plugging in the evaluation board and I see no new entries whatsoever. However when I use lsusb before and after plugging in the device I see a new entry.

This is a fresh install of Ubuntu. I feel like I was able to use minicom in the past on a previous Ubuntu install, but I'm not actually certain about that.

I've tried this to no avail: Re: Need Linux driver support for WICED eval board

Actually, strangely enough, I was able to download to the board via make without doing the configurations detailed in that thread.

Any tips?

This is all new to me. Apologies for my ignorance. Let me know how I can be of more help.

0 Likes
Reply
1 Solution
Employee

Hi,

Please try this:

Setup WICED USB J-TAG connection

a. For Ubuntu 12.04:

Create the /etc/udev/rules.d/70-wiced-JTAG.rules file as follow:

     sudo gedit /etc/udev/rules.d/70-wiced-JTAG.rules

Set the content of the file as following:

# udev rules file for WICED USB JTAG interface, to allow use by non super-users

SUBSYSTEM=="usb", ATTR{idVendor}=="0a5c", ATTR{idProduct}=="43fa", GROUP="hwlab", MODE="0666"

b. Set the serial port:

sudo modprobe ftdi_sio vendor=0x0a5c product=0x43fa


Above line could be inserted into the ~/.bashrc to load FTDI driver at startup.

You may take a look at Setup Eclipse Kepler for WICED SDK on Linux - Ubuntu 14.04 or 12.04 as well.

Thanks,

Seyhan

View solution in original post

8 Replies
Employee

Hi,

Please try this:

Setup WICED USB J-TAG connection

a. For Ubuntu 12.04:

Create the /etc/udev/rules.d/70-wiced-JTAG.rules file as follow:

     sudo gedit /etc/udev/rules.d/70-wiced-JTAG.rules

Set the content of the file as following:

# udev rules file for WICED USB JTAG interface, to allow use by non super-users

SUBSYSTEM=="usb", ATTR{idVendor}=="0a5c", ATTR{idProduct}=="43fa", GROUP="hwlab", MODE="0666"

b. Set the serial port:

sudo modprobe ftdi_sio vendor=0x0a5c product=0x43fa


Above line could be inserted into the ~/.bashrc to load FTDI driver at startup.

You may take a look at Setup Eclipse Kepler for WICED SDK on Linux - Ubuntu 14.04 or 12.04 as well.

Thanks,

Seyhan

View solution in original post

Anonymous
Not applicable

Hi Seyhan,

What about Ubuntu 14.04? I think they soul be same, but;

I set udev rules as you said but still I am not able to see any serial devices sth like ttyUSBx.

What would you offer me about this?

Thanks,

Cagdas.

0 Likes
Reply
Employee

Hi Cagdas,

Setting up the Wiced USB J-Tag connection for Ubuntu 14.04 should be the same as 12.04. Did you try setting it up like in this post,Setup Eclipse Kepler for WICED SDK on Linux - Ubuntu 14.04 or 12.04?

Second, are you using a external USB hub? Is so, try it without the external hub.

Seyhan

Anonymous
Not applicable

Dear Seyhan,

After defining udev rule, I had to manually write your vendor id under usb device's new_id.

Somehow cannot handled via modprobe. But, It works now.

Thanks for your support.

Employee

Hi,

Sounds good, if you need further help please contact us.

Seyhan

0 Likes
Reply
Anonymous
Not applicable

For the benefit of other folks. The procedure to update new_id for serial port to work is below. This needs to  be run as root.

echo "0a5c 43fa" > /sys/bus/usb-serial/drivers/ftdi_sio/new_id

Anonymous
Not applicable

It says "permission denied" even when I do it with "sudo"

0 Likes
Reply
Anonymous
Not applicable

I figured it out. It has to be:

sudo sh -c "echo 0a5c 43fa > /sys/bus/usb-serial/drivers/ftdi_sio/new_id"

This clarification would be useful to people that are new to Linux, I didn't know that I was supposed to do it that way, I was just using sudo echo "0a5c 43fa" > /sys/bus/usb-serial/drivers/ftdi_sio/new_id and it was not working.

Cheers!!

0 Likes
Reply