cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

AsAl_4421831
New Contributor II

Hello Team,

My company is using LBEE5HY1MW in our product. According to the datasheet its support Bluetooth 5.0, However, the LMP version I read through hcitool is 4.1.

I would like to know, does the chip also supports the BLE security as specified in Bluetooth core specification 4.2?

Or does it support any of the Bluetooth 4.2 Core specifications?

The 1MW module in our product is involved in security-related compliance.

Any help is really appreciated.

Thanks,

Asma

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator

Hi,

LBEE5HY1MW based on Cypress CYW43455 combo chipset.

CYW43455 is qualified for and supports the mandatory features of the Bluetooth 5.0 specification and  Bluetooth Baseband Core (BBC)  supports all Bluetooth 4.2 features.

Please see the datasheet. https://www.cypress.com/products/cyw43455 

 

Thanks,

-Dheeraj

View solution in original post

0 Likes
4 Replies
DheerajPK_41
Moderator
Moderator

Hi,

LBEE5HY1MW based on Cypress CYW43455 combo chipset.

CYW43455 is qualified for and supports the mandatory features of the Bluetooth 5.0 specification and  Bluetooth Baseband Core (BBC)  supports all Bluetooth 4.2 features.

Please see the datasheet. https://www.cypress.com/products/cyw43455 

 

Thanks,

-Dheeraj

View solution in original post

0 Likes
AsAl_4421831
New Contributor II

Hi Dheeraj,

Thank you for the reply. One more question is our Bluetooth chip is reporting the LMP version as (0x7 ) 4.1.

Is there any solution to how can I update it to report 5.0 i.e LMP version (0x09)?
Update of firmware files or anything else that I can do?

https://forums.gentoo.org/viewtopic-t-1117192-start-0.html

This forum discussed a similar issue for RPi - they were able to resolve the issue through a firmware update, but I am not sure where did they get firmware files from. Could you please help me?


Thanks,

Asma

0 Likes
AsAl_4421831
New Contributor II

Hi @DheerajPK_41 

Could you provide any update on this, please?

 

Thanks,

Asma

0 Likes
DheerajPK_41
Moderator
Moderator

Could you please contact Murata? The update firmware should be provided by the module vendor.

Thanks,

-Dheeraj

0 Likes