cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

srme_3928751
New Contributor

Hi,

  I have an BCM4355 chip interfaced to SM32MP157 processor,both the drivers for WIFI/BLE are loading.But while running any operation on them I am facing issues.

WIFI Issues:

1.Both AP and STA mode are not running simultaneously at a time only AP mode is running.

2.If I run the wifi supplicant I was getting below errors

[ 1860.606056] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

[ 1861.315129] mmci-pl18x 48004000.sdmmc: unaligned scatterlist: ofst:400 length:472

[ 1861.321174] brcmfmac: brcmf_sdiod_sglist_rw: CMD53 sg block read failed -22

[ 1861.328768] brcmfmac: brcmf_sdio_rxglom: glom read of 1024 bytes failed: -5

[ 1861.335194] brcmfmac: brcmf_sdio_rxfail: abort command, terminate frame

[ 1861.342199] brcmfmac: brcmf_sdio_readframes: brcmf_sdio_readframes: glom superframe w/o descriptor!

[ 1861.350832] brcmfmac: brcmf_sdio_rxfail: terminate frame

[ 1866.775418] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

[ 1867.931267] mmci-pl18x 48004000.sdmmc: unaligned scatterlist: ofst:818 length:116

[ 1867.937425] brcmfmac: brcmf_sdiod_sglist_rw: CMD53 sg block write failed -22

[ 1867.944356] brcmfmac: brcmf_sdio_txfail: sdio error, abort command and terminate frame

BLE Issues:

On boot up I am getting below prints w.r.t Bluetooth

Bluetooth: hci0: command 0x0c03 tx timeout

Bluetooth: hci0: BCM: Reset failed (-110)

If I run the bluetoothctl tool I was returning below error

bluetoothctl

Agent registered

[bluetooth]# power on

No default controller available

  Can anyone help me how to fix these errors for my module.Thanks in advance.

Regards

Srikanth.

0 Likes
1 Solution
VinayakS_26
Moderator
Moderator

Hi,

Could you mention the version of the firmware used for 43455. Also could you check out the following blog setting up an AP.

Concurrent AP and STA

Warm Regards

VinayakS_26

View solution in original post

3 Replies
VinayakS_26
Moderator
Moderator

Hi,

Could you mention the version of the firmware used for 43455. Also could you check out the following blog setting up an AP.

Concurrent AP and STA

Warm Regards

VinayakS_26

View solution in original post

srme_3928751
New Contributor

Hai Vinayak,

  My kernel version is 4.19.9

and  I am attaching the fmac driver code also.I have tried the procedure which you have mentioned for setting AP and STA but didn't work.

Regards

Srikanth.

0 Likes
KaNa_3391246
Valued Contributor II

Hi Srikanth,

Could you please share the dmesg logs that drivers for WIFI/BLE was loaded?

Best regards,

KaNa_3391246

0 Likes