cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

leomecma
New Contributor

I have a WIFI/BT module from USI that uses the 43438 chipset. This module is connected to an IMX6 processor running Android 9. Bluetooth classic and BLE client works well, but BLE server (advertiser) not.

Using BLE apps from PlayStore I get messages like your device doesnt support this functionality or more specific ADVERTISE_FAILED_TOO_MANY_ADVERTISERS. 

USI has send me a more recent HCD file, but not work too. Could someone with experience at BLE and Android give me some directions about this? What I need to do to enable BLE server in Android? Is something related to HCD or libbt?

 

Thanks,

Leonardo

0 Likes
1 Reply
Zhengbao_Zhang
Moderator
Moderator

Hello:

 Would you please update logcat and btsnoop for a review ? thanks.

0 Likes