cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

New Contributor

i have loading driver modules for my wifi AP6212(BRCM43430),when i ifconfig wlan0 up and start up the hostapd service i can find the hotpot, but when i running a application  of video in and out to lcd with mcu of hisi3519v101, the hotpot will disappeared immediately. also i try to start up the application firstly and then to run hostapd, the log shows that the ap enabled,but i can't find hotpot neither. do some guys have the same exprience(my kernel is 3.18, and the wifi driver backports form 4.14.77, using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001, Firmware version = wl0: May  2 2019 02:39:18 version 7.45.98.83 (r714225 CY) FWID 01-e539531f)?

the log is:

first: i run hostapd and then run the application ,

~ # ifconfig wlan0 192.168.1.1

IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

~ # hostapd -B /etc/wireless/hostapd.conf

Configuration file: /etc/wireless/hostapd.conf

wlan0: Could not connect to kernel driver

Using interface wlan0 with hwaddr 18:93:7f:36:36:0e and ssid "AP6212"

IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

wlan0: interface state UNINITIALIZED->ENABLED

wlan0: AP-ENABLED

~ #

here i can find the hotpot. then i run the application, the hotpot will disappear.

second: i run application and then run the hostapd,

~ # cd /modules

/modules # ./sample_venc &

/modules # station num = 17

[key_dev_set_irq 9]uv_irq_type = 2

[key_dev_set_irq 108]gpio_irq_type = 2

[key_dev_set_irq 109]gpio_irq_type = 2

[key_dev_set_irq 117]gpio_irq_type = 2

[key_dev_set_irq 8]gpio_irq_type = 2

============= MipiDev 0, SetMipiAttr enWDRMode: 0

SAMPLE_COMM_ISP_Sensor_Regiter_callback isp_dev = 0

Func: SAMPLE_COMM_ISP_Init, Line: 691, WDR Mode: 0

stPubAttr (0, 0, 1920, 1080, 30.000000)

linear mode

-------Sony IMX323 Sensor 1080p_30fps_raw12_cmos_37p125Mhz Initial OK!-------

Func: SAMPLE_COMM_ISP_Init, Line: 716 end IspDev:0.

ISP Dev 0 HI_MPI_ISP_Run

u32Width:240, u32Square:1

the bat_volume is 524 the bat_scale is 7

register cm :09 = val: e0630400

LCD initial end

ifconfig wlan0 192.168.1.1

IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

/modules # hostapd -B /etc/wireless/hostapd.conf

Configuration file: /etc/wireless/hostapd.conf

wlan0: Could not connect to kernel driver

Using interface wlan0 with hwaddr 18:93:7f:36:36:0e and ssid "AP6212"

IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

wlan0: interface state UNINITIALIZED->ENABLED

wlan0: AP-ENABLED

/modules #

here i can't find the hotpot. even sometimes i will get some failure info when i run hostapd;

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_start_ap: SET SSID error (-110)

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_set_mpc: fail to set mpc

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

Failed to set beacon parameters

wlan0: Could not connect to kernel driver

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_del_station: SCB_DEAUTHENTICATE_FOR_REASON failed -110

Interface initialization failed

wlan0: interface state UNINITIALIZED->DISABLED

wlan0: AP-DISABLED

wlan0: Unable to setup interface.

wlan0: interface state DISABLED->DISABLED

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_del_station: SCB_DEAUTHENTICATE_FOR_REASON failed -110

wlan0: AP-DISABLED

hostapd_free_hapd_data: Interface wlan0 wasn't started

nl80211: deinit ifname=wlan0 disabled_11b_rates=0

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_change_iface: WLC_SET_INFRA error (-110)

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_get_tx_power: error (-110)

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: brcmf_cfg80211_get_channel: chanspec failed (-110)

brcmfmac: brcmf_cfg80211_get_tx_power: error (-512)

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: _brcmf_set_multicast_list: Setting mcast_list failed, -110

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: _brcmf_set_multicast_list: Setting allmulti failed, -110

brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout

brcmfmac: _brcmf_set_multicast_list: Setting BRCMF_C_SET_PROMISC failed, -110

brcmfmac: brcmf_cfg80211_change_iface: WLC_SET_INFRA error (-110)

thanks!

0 Likes
Reply
1 Solution
Moderator
Moderator

As chip down opportunities are not supported on the community, which BCM43430 (Broadcom PN) partner module are you using in your design?

View solution in original post

0 Likes
Reply
2 Replies
Moderator
Moderator

As chip down opportunities are not supported on the community, which BCM43430 (Broadcom PN) partner module are you using in your design?

View solution in original post

0 Likes
Reply
New Contributor

Ampak AP6212 43430

0 Likes
Reply