cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

veb_4093841
New Contributor II

We are using CYW943907AEVAL1F - Free RTOS - LwIP  & WICED 6.4. WIFI works with 5Ghz Band.

We are streaming the audio over wifi. During the steaming some times "wiced_audio_wait_buffer" return error : 2 (TIMEOUT)

is there any recommendation to recover from this scenario ?

0 Likes
4 Replies
KotnaniK_71
Employee

Hi,

What's the application you're using in WICED 6.4?

Can you please share your code example or let us know the steps to reproduce the issue.

Thanks.

veb_4093841
New Contributor II

Hi

we are seeing this issue with our custom audio streaming application over UDP. Issue is seen randomly.

We are using the wiced audio driver by enabling WICED_USE_AUDIO macro, with is Below configuration.

static wiced_audio_config_t config =

{

    .sample_rate        = 16000,

    .channels           = 2,

    .bits_per_sample    = 16,

    .frame_size         = 4,

};

WICED_AUDIO_DEVICE_PERIOD_SIZE = 1024

BUFFER_WAIT_TIME_MS         1000

0 Likes
KotnaniK_71
Employee

Hi,

It's very difficult for us to debug and reproduce the issue without knowing the detailed configuration setup about streaming the audio over Wifi as we requested you to provide that information in community private chat.

If you're still facing the issue, I request you to please contact our local sales/marketing team with this thread as reference and they should be able to help you out.

Thanks.

0 Likes
KotnaniK_71
Employee

Hi,

Please create a new thread if you face any issues or need any help in future.

I have locked this thread because of inactivity.

Thanks.

0 Likes