cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

Anonymous
Not applicable

HI,

I've been running lwip stack for quite some time now, but never encountered this error while sending a tcp packet. recently I started getting ERR_WOULDBLOCK return when sending a packet. Can anyone help me with debugging why this issue occurs?

0 Likes
Reply
18 Replies
Anonymous
Not applicable

Hey,

Could you share the SDK version that you are using?

I guess the ERR_WOULDBLOCK was a bug in lwip which was fixed in release 1.4.0.

You may want to refer this discussion:-

Re: [lwip-users] 1.4 rc1 non-blocking issues

Best Regards,

AB

0 Likes
Reply
Anonymous
Not applicable

Then a better fix is to upgrade the LwIP version in the SDK.

All available release of WICED SDK uses LwIP-v1.4.0.rc1.

LwIP v1.4.0 is not updated for a long time, v1.4.1 is better.

I'm wondering if Broadcom has a plan to upgrade LwIP or not.

0 Likes
Reply
Contributor

We manually upgraded our LWIP version to 1.4.1 and brought in our personalized changes as well as the WICED changes.  Seems to work  fine.  Several people on the forum have offered to send the upgraded LWIP to broadcom, they never accepted.

0 Likes
Reply
Anonymous
Not applicable

I know people can manually upgrade LwIP.

My point is if Broadcom can officially upgrade LwIP in new SDK,

it's supposed to be well tested and more people get benefit.

0 Likes
Reply
Anonymous
Not applicable

sam.lin and felix_turgeon

Please PM me regarding any community ports of LwIP that has been tested extensively with the SDK >= 3.3.1 that you would like us to incorporate into the standard SDK.

0 Likes
Reply
Contributor

nsankar mwf_mmfae

We did not upgrade to 3.3.1 because the change set did not seem like it would buy us anything.   I used the same port of LWIP 1.4.1 that I had made for WICED 2.4 when we upgraded to WICED 3.1.2 without any more modifications. So far the behavior has been consistent.  When we had first looked at WICED 3.1.2 we compared LWIP 1.4.0rc1 in WICED 2.4 to LWIP 1.4.0rc1 in WICED 3.1.2 and they appeared identical.  If there are still no changes to LWIP 1.4.0rc1 in WICED 3.3.1, then I can send you our LWIP 1.4.1 to work with WICED.  We made some more changes to work with our system (that I can revert since they only apply to us), and mitigated a bug we noticed.

I don't know how to PM you.  I haven't found a place where I can initiate a PM.

0 Likes
Reply
Anonymous
Not applicable

hi felix_turgeon,

We also use sdk-3.1.2 which I think is the most stable version so far.

When I test LwIP-v1.4.1 it looks ok in STA mode, but when I run the device

in AP mode my PC cannot successfully associate the AP.

Does LwIP-v1.4.1 work for AP mode in your test?

I test the LwIP-v1.4.1 from jasonpark's port which is available at  https://community.broadcom.com/servlet/JiveServlet/download/17685-6824/WICED-SDK-3.3.1-LwIP-1.4.1.7z...

0 Likes
Reply
Moderator
Moderator

You can send a PM to nsankar from your inbox on the Community.  Take a look at the screenshot below.inbox.png

0 Likes
Reply
Contributor

That button doesn't exist for me.

WicedInbox.png

As far as the LWIP 1.4.1 version is concerned, I need to strip out some mods we made to get it to compile on our system.  If we figure out how to PM I will be glad to send it to whomever.

0 Likes
Reply
New Contributor

My apologies.  Click the username of the person in the thread, and it will take you to a screen like the one shown below (click the "message" button to send them a note).  This is what I see when I am logged in as my test user.

Keep in mind that you cannot include attachments, so they will need to provide their email address.

message2.png

0 Likes
Reply
Contributor

No button for me. I also can't follow anymore.  I used to be able to before the new forum format.

WicedSend.png

0 Likes
Reply
Moderator
Moderator

Which browser?  Everything on the platform is Java based, so each time there is a change, it seems that several cache clearing, browser opening and closing exercises are needed before everything is back to normal.  I am using IE 11 if that helps. But it also works fine for me under the latest version of Firefox.

Is anyone else having the same issue?

megan.truett@jcsconsulting.com

Contributor

I am using Chrome 64-bit.

I can confirm that it works with Fire Fox, I'll just use Fire Fox for the PMs.

Thanks

Anonymous
Not applicable

Thanks, Felix! That makes sense since 64b is simplified and might take out certain features.

0 Likes
Reply
Anonymous
Not applicable

Hi felix_turgeon,

I'm interested in your LWIP 1.4.1 prot and I can help testing it as well.

So please CC me as well or just post it on the forum.

Thanks.

0 Likes
Reply
Anonymous
Not applicable

We are using SDK 3.3.1, I rarely faced this problem with sdk 3.1.2 but after upgrading to 3.3.1 this became more frequent. lwip is LwIP-v1.4.0.rc1

0 Likes
Reply
Anonymous
Not applicable

I tried the lwip-v1.4.1 port from both jasonpark and felix.

Both versions have the same issue when device is running as AP mode.

My PC fails to connect the device (in AP mode).

After debug a while, I figure out the problem is in DHCP.

If I use static IP to assocate the AP, it's fine.

Adding debug code in dhcp_server, it shows the wiced_udp_receive does not

get any data. Any suggestion to debug this issue?

0 Likes
Reply
Contributor

My first question would be, are you achieving a complete DHCP negotiation on your module before even attempting any connection to your module?

0 Likes
Reply