cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

Anonymous
Not applicable

Hi,

Iam using Discover wi-fi STM32F4DIS module.  If Uart TX and RX pin of wi-fi module is connected with external device which has Arm cortex M0 processor, data is not received. If RX pin is disconnected data is received. What is the problem...How to resolve it....

Thank you!!!!!!!!!!

0 Likes
Reply
1 Solution
Moderator
Moderator

Check the return value of wiced_uart_receive_bytes() when the wifi module does not receive data. I want to know whether the function fails in this situation. Also use a CRO and check if you could obtain signal at Wifi rx=>BLE-tx line. Check whether disabling wifi and BLE in both devices has any effect.

View solution in original post

5 Replies
Moderator
Moderator

Your question is not clear. Which device is receiving the data? Is it the wi-fi module or the ARM cortex M0 processor? From the statement "If RX pin is disconnected data is received" it seems that the ARM processor is the receiving device. Are you getting the same problem when you interface the Wi-fi module with other processors? Can you share the code files for analysis?

0 Likes
Reply
Anonymous
Not applicable

hi,

Wifi module is receiving data from external device...if both RX and TX pin of wifi module and external device's TX and Rx are connected, wifi module is not receiving data from the external device.

wifi                External device

TX pin    -->     RX pin   

RX pin   -->      TX pin

If TX pin of wifi module and RX pin of external device is disconnected, wifi module is receiving the data from the external device

0 Likes
Reply
Moderator
Moderator

Are you performing transmission and reception simultaneously? Or irrespective of whether wifi module transmits data or not, are you still getting this problem? Disable flow control in both devices if it is enabled.

0 Likes
Reply
Anonymous
Not applicable

Hi ,

Thank you for your immediate reply

I am receiving data via UART interface SN8200 Discover WIFI module from External  BLE ,

WIFI   BLE DEV Board

TX   =>    RX

RX   <=    TX  , In External  BLE  (with both HW/SWflow control and sleep disabled) tx data  data to WIFI , when both WIFI-tx => BLE-rx and WIFI-rx => BLE-tx connected , wifi board not receiving any data ,

If only wifi-rx => BLE-tx , wifi is getting data , what could be the issue ??

While using RS232 to see data in TERATERM , WIFI is not transmitting any data , only receiving from BLE external device

0 Likes
Reply
Moderator
Moderator

Check the return value of wiced_uart_receive_bytes() when the wifi module does not receive data. I want to know whether the function fails in this situation. Also use a CRO and check if you could obtain signal at Wifi rx=>BLE-tx line. Check whether disabling wifi and BLE in both devices has any effect.

View solution in original post