cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

New Contributor

Hi,

Currently working on ISM43362-M3G-L44-E/U serial-to-Wifi module.

Using WICKED STUDIO to build and ST-Link utility software to flash the binary files externally.

From my understanding we have to flash three .bin files(Correct me if I'm wrong)

- Bootloader .

- DCT and Application.

I had few question:

-  How should be the flash address given  for each file? and what is the order of flashing ? .

- Should all be merged and flashed in single shot?.

-  Is there any other file  that I'm missing?

Please give me your ideas on this.

Thanks In advance

JD

0 Likes
Reply
3 Replies
Moderator
Moderator

Order is Bootloader, DCT and then application (if you are not downloading wlan firmware and clm blob as a separate filesystem). If you have enabled VERBOSE=1 in your make target, you would be able to see the starting address. In some cases, manually you might need to enable the address printing in the makefiles. But I would recommend, instead of doing that you can use existing openocd support for st-link inside WICED Studio. In your plaform.mk file, can you try adding

HOST_OPENOCD := scripts/target/stm32f4x_stlink

JTAG        := scripts/interface/stlink-v2

and see if that solves your issue.

If you are facing some issue in getting through with the above mentioned approach, you can try Adding ST-Link support in WICED

New Contributor

Hi RaktimR_11

- I tried adding below in plaform.mk file ,in my case ISM43362_M3G_L44.mk

pastedImage_1.png

Found bellow error:

Downloading Bootloader ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading DCT ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading Application ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Build complete

Making .gdbinit

- Next worked around Adding ST-Link support in WICED

Ended up with same above error

Is there something else I should try?

Thanks

JD

0 Likes
Reply
Moderator
Moderator

OpenOCD in WICED recognizes libusbK driver only. So, you might need to use something like Zadig to update the standard st-link Debug interface as a libusbK device.

pastedImage_0.png

With both the options provided above, if you are still facing issue can you check the openocd_log.txt as generated in WICED Build directory and see what is the error you are receiving.

0 Likes
Reply