cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

AxLi_1746341
Honored Contributor

Hi vsha

Sending https request to https://3bbimfjrui.execute-api.us-east-1.amazonaws.com/prod/reportfromingics

always returns 5018 (TLS_ERROR_FATAL_ALERT_MESSAGE) error.

The same issue happens on SDK-3.1.2 and SDK-3.7.0-7.

I'm wondering if this is a known issue?

Note, it works if I test using curl or wget.

0 Likes
1 Solution
Anonymous
Not applicable

HTTPBIN org server is expecting TLS extension [ server name indication ] from client. Httpbin_org is using new implementation of HTTP library so it has option where we can specify SNI and it is able to connect to server. https_client snippet application is using older implementation of HTTP library so it doesn’t have option to specify SNI and it won’t be able to connect to httpbin_org server.  We recommend to use new version of HTTP library [ httpbin_org snippet ]. As older version of HTTP library may get deprecated.

View solution in original post

5 Replies
Anonymous
Not applicable

This message will comes from the server, when client send something which server doesn't like. This may occur in many cases where server will send Alert messages. Please look at the Wireshark logs and check in which portion of TLS handshake the alert is coming.

AxLi_1746341
Honored Contributor

Can you test sending https request to above URL?

0 Likes
AxLi_1746341
Honored Contributor

The problem is missing SNI support.

Anonymous
Not applicable

HTTPBIN org server is expecting TLS extension [ server name indication ] from client. Httpbin_org is using new implementation of HTTP library so it has option where we can specify SNI and it is able to connect to server. https_client snippet application is using older implementation of HTTP library so it doesn’t have option to specify SNI and it won’t be able to connect to httpbin_org server.  We recommend to use new version of HTTP library [ httpbin_org snippet ]. As older version of HTTP library may get deprecated.

View solution in original post

AxLi_1746341
Honored Contributor

https_client can support SNI if you preperly update the snip code.

Please don't easily remove a existing library which is already used by some users.

0 Likes