cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

veb_4093841
New Contributor II

We are using CYW943907AEVAL1F - Free RTOS - LwIP  & WICED 6.4. WIFI works with 5Ghz Band.

In our system there will be 8 STA's works with the above said environment.

When the STA tries to Join the Soft AP, some time we see the below error. The error code "1006" ,  "1024"  corresponds to  "Not authenticated " , "Specified network was not found " respectively. 

image.png

Regards

venkatesh

0 Likes
1 Solution
veb_4093841
New Contributor II

Hi,

As part of the device Association process, all the STA's are very close to AP. All the 8 STA's are lesser than 1 feet distance from the AP. Having the 8 Devices close can cause this type of behavior ?

Not doing the scan before connecting to AP, as during the association AP & STA are expected to be very close and SSID & Passphrase are Fixed.

View solution in original post

0 Likes
4 Replies
Charles_Lai
Moderator
Moderator

Hi,

"Not authenticated " or "Specified network was not found " often indicates that the signal of the AP is weak.

Have you tried to do a scan before connecting to the AP and see if the AP can be found or the RSSI is low?

Try to shorten the distance or amplify the signal to see if it helps.

Best regards

0 Likes
veb_4093841
New Contributor II

Hi,

As part of the device Association process, all the STA's are very close to AP. All the 8 STA's are lesser than 1 feet distance from the AP. Having the 8 Devices close can cause this type of behavior ?

Not doing the scan before connecting to AP, as during the association AP & STA are expected to be very close and SSID & Passphrase are Fixed.

View solution in original post

0 Likes
Charles_Lai
Moderator
Moderator

Hi,

I think the antenna of your device can be malfunctioning. Though the STA is close to the AP, it is still difficult to start communication, resulting in the error codes you saw.

To verify this cause, you can do a scan to see if the STA can capture the AP's signal soundly. To be more rigorous, you should also get the RSSI result at the AP side to see if the STA is transmitting well and the AP is capturing the STA soundly during the connection.

I think it's best to confirm this at first, based on the error code we saw, rather than investigating other less relevant causes right away.

Best regards

0 Likes
veb_4093841
New Contributor II

Hi,

Did try to scan the AP (SSID - "ACT" ) and join upon Found the AP. With this approach SSID is visible in scan list but is failing to join. Below is the console log detailing the RSSI & Error Code.

pastedImage_0.png

0 Likes