cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

Félix_T
Contributor
We have recently ported WICED, WWD and LwIP to use u-Velocity.  All components seem to work correctly.  Our issue is with the firmware programming part of the chip bringup.  After the firmware is downloaded and the NVRAM image is downloaded, the function wiced_download_firmware waits for the WLAN component to come back up.  At least that is what the comments in the code says.  Any clue why the WLAN component would successfully download the firmware and NVRAM but not correctly come back up?

Here is the code snippet that always timesout:

/* Wait until the High Throughput clock is available */

    loop_count = 0;

    while ( ( ( result = wiced_read_register_value( BACKPLANE_FUNCTION, SDIO_CHIP_CLOCK_CSR, (uint8_t) 1, &csr_val ) ) == WICED_SUCCESS ) &&

            ( ( csr_val & SBSDIO_HT_AVAIL ) == 0 ) &&

            ( loop_count < (uint32_t) HT_AVAIL_TIMEOUT_MS ) )

    {

        (void) host_rtos_delay_milliseconds( (uint32_t) 1 ); /* Ignore return - nothing can be done if it fails */

        loop_count++;

    }

    if ( loop_count >= (uint32_t) HT_AVAIL_TIMEOUT_MS )

    {

        /* If your system times out here, it means that the WLAN firmware is not booting.

         * Check that your WLAN chip matches the wifi_image.c being built - in GNU toolchain, $(CHIP)

         * makefile variable must be correct.

         */

         WPRINT_WWD_ERROR(("Timeout while waiting for high throughput clock

"));

        return WICED_TIMEOUT;

    }
0 Likes
1 Solution
Félix_T
Contributor
Sorry for the delayed reply.

We switched to a BCM43362 and our port of WWD and LWIP worked correctly with wiced.

Thanks.

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable
WICED currently does not provide a WLAN firmware image compatible with the BCM4330.

Are you using the 43362 image or have you sourced a 4330 image from elsewhere?

Without the correct image the WLAN chip will not boot up even though the firmware and NVRAM are sucessfully downloaded.
0 Likes
Félix_T
Contributor
Sorry for the delayed reply.

We switched to a BCM43362 and our port of WWD and LWIP worked correctly with wiced.

Thanks.

View solution in original post

0 Likes