cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

New Contributor

We have designed a custom board using Murata type1LD and i'am using 43xxx_WIFI example to flash the board using segger J-Link EDU but i am getting the following errors.

Downloading Bootloader ...

Building apps lookup table

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading DCT ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading resources filesystem ... build/snip.scan-MurataType1LD/filesystem.bin at sector 1  size 96...

tools/makefiles/wiced_apps.mk:334: recipe for target 'FILESYSTEM_IMAGE_DOWNLOAD' failed

make.exe[1]: *** [FILESYSTEM_IMAGE_DOWNLOAD] Error 1

make.exe[1]: *** Waiting for unfinished jobs....

Makefile:351: recipe for target 'main_app' failed

make: *** [main_app] Error 2

my doubt is should we use Olimex USB JTAG Tiny (or Tiny-H) programmer or any other Programmer, in my case i am using segger J-Link EDU and i'am using WICED-studio-6.2.

Please help me to resolve this issue

0 Likes
Reply
5 Replies
Moderator
Moderator

Did you obtain the Type 1LD platform files from Murata?

ToIn_1742091

0 Likes
Reply
New Contributor

Hi Michael,

Thanks for your response, yes i have received platform files from Murata, but i'am not getting how to flash to the board,which segger to use and where to get debug messages from the board.

0 Likes
Reply
New Contributor

pastedImage_1.png

0 Likes
Reply
New Contributor II

if you are using 1LD evb board - make sure you connected the usb to USB1 ( closer to the 1LD )

Also , check if openocd process running - if yes close it and try to run again

New Contributor

Thanks for your response, i'am using custom based board Murata Type1ld to which i have pulled out j-link pins and connected to segger J-link  in which i have changed j-link driver to libusb32 and i'am using wifi eg to flash to the  Murata board but i am getting this errors.

Downloading DCT ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

0 Likes
Reply