cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

New Contributor

I am using 4390 module for our product and we set the module to be working as an AP.  And I am seeing some TCP packet losses and TCP socket disconnections during the data transmit from the module.

To isolate the issue, I want to give it a try with fixed wifi mode: 11b only or 11g only.  Can someone help to let me know how to set the 4390 wifi mode as 11b only,  11g only mode or 11n only mode?

Thanks

0 Likes
Reply
1 Solution
Honored Contributor

There is a wwd_wifi_set_11n_support() function to allow disable 11n.

But I don't know any function for 11b/g/n only.

Which network stack are you using? NetX/NetX_Duo/LwIP?

View solution in original post

0 Likes
Reply
13 Replies
Honored Contributor

Which sdk version are you using? and which network stack are you using?

0 Likes
Reply
Honored Contributor

There is a wwd_wifi_set_11n_support() function to allow disable 11n.

But I don't know any function for 11b/g/n only.

Which network stack are you using? NetX/NetX_Duo/LwIP?

View solution in original post

0 Likes
Reply
New Contributor

NetX_Duo is the network stack we used.

Thanks

0 Likes
Reply
Honored Contributor

I personally don't think it's related to b/g/n.

Maybe you can compare with different network stack build.

BTW, you should also check if newer sdks fixes the issue.

0 Likes
Reply
New Contributor

Thanks for your comment.  I will check if newer version of sdks works ok.

However, I cannot find BCM94390WCD2 platform in newer version SDKs - 4.0 or later..

Anyway, I will reopen this issue in a different name later.

0 Likes
Reply
Honored Contributor

obewon wrote:

Thanks for your comment.  I will check if newer version of sdks works ok.

However, I cannot find BCM94390WCD2 platform in newer version SDKs - 4.0 or later..

SDK-3.7.0-7 is the latest sdk supporting 4390.

New Contributor

Hello,

I have tried with SDK-3.7.0-7 as you recommended.

It kept failing as below. I have applied apsta and otr sample code to the SPIL module EVB board (SB-WM-N03).

Is v3.7.0-7 fully tested for apsta mode? 

Starting WICED v3.7.0

Platform BCM94390WCD2 initialised

Started ThreadX v5.6

Initialising NetX_Duo v5.7_sp2

Creating Packet pools

Hi, I'm the Production App (ota_fr).

Watch while I toggle some LEDs ...

Time for an upgrade. OTA upgrade starting ...

Error: wwd_wifi_start_ap failed

Thanks

0 Likes
Reply
Honored Contributor

obewon wrote:

Hello,

I have tried with SDK-3.7.0-7 as you recommended.

It kept failing as below. I have applied apsta and otr sample code to the SPIL module EVB board (SB-WM-N03).

Is v3.7.0-7 fully tested for apsta mode? 

I don't use ap and sta interfaces at the same time.

Maybe someone from cypress can take check this...

0 Likes
Reply
New Contributor

Thanks for your comments.

I have not used both ap and sta at the same time. I only loaded the sample image from apsta folder from the SDK and set it as an AP.

So, I guess you have not tried SDK-3.7.0-7 in an AP mode. Am I correct?

We have also tested other SDK versions v3.5 also showed similar instability issue.

0 Likes
Reply
Honored Contributor

I use FreeRTOS build and I have a lot of fixes to the SDK.

Honestly, I think cypress remove BCM4390 platform from SDK too early.

There are many bug fixes in newer sdks which are platform independent.

Some of the bug fixes with source code, so you can probably backport it.

However, there are also many bug fixes in closed source library, in this

case it's hard to get fix for BCM4390.

New Contributor

Thanks for your comment.

However, it is really disappointing since we launched our product with 4390 last year.

I am afraid that we might have to decide switch the solution then.

0 Likes
Reply
Honored Contributor

Won Sang Cho wrote:

Hello,

I have tried with SDK-3.7.0-7 as you recommended.

It kept failing as below. I have applied apsta and otr sample code to the SPIL module EVB board (SB-WM-N03).

Is v3.7.0-7 fully tested for apsta mode? 

Starting WICED v3.7.0

Platform BCM94390WCD2 initialised

Started ThreadX v5.6

Initialising NetX_Duo v5.7_sp2

Creating Packet pools

Hi, I'm the Production App (ota_fr).

Watch while I toggle some LEDs ...

Time for an upgrade. OTA upgrade starting ...

Error: wwd_wifi_start_ap failed

Thanks

From your boot message, the wlan firmware is not loaded at all.

That is why wwd_wifi_start_ap fails.

0 Likes
Reply