cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

GaK_4661021
New Contributor II

Hi,

We are testing mesh gateway firmware from https://github.com/cypresssemiconductorco/mbed-os-example-bluetooth-mesh-gateway. We are facing a compilation issue with the above firmware. Below is the setup details,

1. System: Windows 10 64Bit

2. Python: Python 3.7.9

We are attaching an error screenshot for your reference. We have tried to remove the "-std=gnu++14" flag from JSON files present in the "mbed-os\tools\profiles" directory but it results in other errors.

Please help with this issue.

0 Likes
1 Solution
MuraliR_36
Moderator
Moderator

The board needs to be in CMSIS-DAPLink mode for it to work it mbed. Can you try changing the mode from Kitprog3 to the mentioned one using the SW3 button and try.

View solution in original post

0 Likes
6 Replies
MuraliR_36
Moderator
Moderator

@GaK_4661021 

Even I have the same setup and I just checked out the attached code example and the compilation went through just fine. Attached is the log for your reference.

MuraliR_36_0-1614750932856.png

In your logs I see a warning where it says that it needs a different compiler version. Can you change this, clone the example again and retry?

 

Thanks

0 Likes
GaK_4661021
New Contributor II

Hi,

Thanks for the quick update. Yes, that was the issue. I am able to compile firmware now but facing an issue with the firmware flashing. I am attaching an error screenshot for your reference. The board is connected with the PC and I am able to flash the firmware on board by using "Eclipse IDE for ModusToolbox". I am using the KITPROG3 connector of the board for the programming.

Can you please help with the issue?

0 Likes
MuraliR_36
Moderator
Moderator

The board needs to be in CMSIS-DAPLink mode for it to work it mbed. Can you try changing the mode from Kitprog3 to the mentioned one using the SW3 button and try.

View solution in original post

0 Likes
GaK_4661021
New Contributor II

@MuraliR_36 

Thanks for the quick update. That was the issue. We are now able to flash the firmware. We are following "\peerapp\README.md" guide to setup the BLE mesh gateway network. We are able to make the network and it is controllable from a mobile application in "HOME" mode but we are not able to control the devices in "AWAY" mode. We are using AWS IoT as a cloud and followed all the steps mentioned in the readme in order to set up the network(Including AWS.conf file modification and copying to the mobile phone as per the account details). An internet connection of mobile and device is working as expected but the control part is not working.

Can you please help with this?

Let us know if you require more details about this issue.

0 Likes
GaK_4661021
New Contributor II

@MuraliR_36 

Can you please help with this issue?

0 Likes
MuraliR_36
Moderator
Moderator

Since the original issue reported was resolved, can you create this new issue in another thread if you are still facing it, so that the visibility improves for the rest of the community.

Thanks

0 Likes