cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

BeCo_289361
New Contributor

I have three CY8CKIT-062-WiFi-BT. Out of the box all kits are able to be programmed with wiced examples.

I have done the following with two of the three kits:

I used fw-loader to upgrade to KitProg3 so I could try modus.

I used fw-loader to downgrade to KitProg2 so I could go back to wiced.

Since I went back to KitProg2 I have not been able to program with wiced. See error below.

According to the documentation I should be able to use fw-loader to switch between KitProg2 and KitProg3. This does not work for me.

I have tried every possible led configuration

The board with original kitprog2 works fine.

The two boards that went to kitprog3 and then back to kitprog2 do not work.

Thoughts?

Error:

Downloading Bootloader ...

Building apps lookup table

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading DCT ...

"**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

Downloading resources filesystem ... build/ww101.02.04_button-CY8CKIT_062/filesystem.bin at sector 1  size 104...

tools/makefiles/wiced_apps.mk:335: recipe for target 'FILESYSTEM_IMAGE_DOWNLOAD' failed

make.exe[1]: *** [FILESYSTEM_IMAGE_DOWNLOAD] Error 1

make: *** [main_app] Error 2

Makefile:351: recipe for target 'main_app' failed

0 Likes
1 Solution
WiWi_4702256
Contributor II

OpenOCD Failed, CY8CKIT-WiFi-BT Pioneer Kit

You may want to follow this thread... I added some of my trials and tribulations...

(note: I am using Windows 7 Pro so it may differ but should be very similar under Windows 10)

In Windows 10; click "search" icon, in search type "device installation settings"

click "no"; save

go to device manager select the port, make sure the device is plugged in and in correct mode... or at least the Programmer states it is in dap mode, the devkit may have led2 and led4 lit and steady, that is the mode I performed the steps in, afterwards, I got the correct indication from the dev kit of led4 lit and no other led's were lit. That is correct mode to program with WICED...

Portable_Devices.jpg

Right click and select update driver and select browse my computer

BrowseMyComputer.jpgLetMePick.jpg

Then let me pick, untick "show compatible hardware"; select Cypress; select Wiced Peripheral UART

SelectWicedDriverUart.jpg

Select "have disk"

Navigate to C:(where ever you have WICED installed..)\WICED-Studio-6.4\Drivers\Windows\wiced_uart

Select wicedport.inf

wicedport.jpg

Let that install...

Now it may Let you know "installing new device" or not, it not unplug DevKit and plug it back in. Make SURE that you did these steps!!!:

In Windows 10; click "search" icon, in search type "device installation settings"; click "no"; save

Anyway you will see the "installing new device" then, go to device manager, your goal is to see the kitProg2 device under Portable Devices"

Portable_Devices.jpg

Here is what I think happened, you had it installed properly, when you powered off and back on Windows 10 in its infinite wisdom installed the driver that "it" thought was best. I read an article about that, I've read so many articles, I could not re-reference it... But they were only speaking about Windows 7 which, I've never had as much issues with, as I have with Windows 10!!! which "they" shoved down our throats imho... Oh... uh I guess that is not nice

View solution in original post

31 Replies
BeCo_289361
New Contributor

Other things I have tried:

Plugged both boards into computer at the same time and compared properties of KitProg2 via windows device manager. The only difference is install date. All other pertinent info is the same (version, etc).

On my untouched board, the one that still works, led4 (power) is the only led that is lit. When the problem boards are in this same configuration they produce the error.

0 Likes
BeCo_289361
New Contributor

The plot thickens. See psoc programmer image below. Under Port Selection there are two entries. The first one is for the board that works. The second one is for the board that does not work.

pastedImage_1.png

The following warning pops up whenever I plug any board in while psoc programmer is running. The update firmware button is always disabled.

pastedImage_0.png

0 Likes
BeCo_289361
New Contributor

Just to clarify, I am not using psoc programmer to program. Just to help debug this issue.

0 Likes
AditiB_81
Moderator
Moderator

Hi,

On the CY8CKIT062-WIFI BT board, there is a mode select switch (S3). Press the SW3 button on your board. After this, LED2 and LED4 will be lit. You will be able to program your board in WICED since the kit is now in HID Mode.

Thanks

0 Likes
BeCo_289361
New Contributor

Thanks for your response AditiB_81. I forgot to mention that previously I tried every possible configuration that SW3 provides with no luck. The following screenshot illustrates the result of trying to download with LED2 and LED4 lit.

pastedImage_0.png

0 Likes
AditiB_81
Moderator
Moderator

Hi,

You can use fw-loader(Firmware Loader) from Modus Toolbox 2.1 release.You can display the list of your connected devices and can get the information of the mode of your connected device using this fw-loader by using the command fw-loader --device-list. Could you please check this command and attach the screenshot of the same?

Thanks

0 Likes
BeCo_289361
New Contributor

Here are both boards with LEDs 2 and 4 lit:

pastedImage_0.png

Neither board can be programmed in this configuration. Both return this error: "**** OpenOCD failed..."

This is the same error returned when no boards are plugged in. This has to be an important  clue.

Here are both boards with only LED4 lit:

pastedImage_1.png

The good board (1719...) can be programmed just fine.

The bad board (1C21...) returns "**** OpenOCD failed..." as if the board is not recognised or not plugged in at all.

See image I posted on April 22, 2020 7:58 AM for complete error.

0 Likes
SanjeevG_16
Employee

Hi BeCo_289361​,

First of all, I tried programming a WICED Project with KitProg3 HID mode (LED4 will be lit and LED2 will function as a breathing LED) and it works fine. To toggle to HID mode without pressing SW3, in the FW-loader, use the command fw-loader --mode kp3-hid.

Second, I could not see any issues with toggling between KitProg 3 and KitProg 2. KitProg2 HID mode appears as a mass storage device (like a USB drive - KitProg2 (D:)). If you view the Device Manager by 'Devices by connection', the KitProg 2 HID appears like the image shown below.

pastedImage_0.png

As AditiB_81 mentioned, WICED projects can be programmed only in HID mode (Correction: Only LED4 will be lit)

-73.

0 Likes
BeCo_289361
New Contributor
8. Re: Cannot program WiFi BT Pioneer Kit after switching to kitprog3 and then back to kitprog2

I can't get only LED4 to be lit. I have tried with SW3 and fw-loader. The modes do appear to change according to "fw-loader --device-list", however, LED4 is never the only LED lit. When downloading with kitProg3 the error is always the same as illustrated in my Apr 22, 2020 7:58 AM post.

KitProg2 results:

Only LED 4 is lit. Still get same error. Our device managers are very different. Am I missing a driver?

pastedImage_6.png

pastedImage_7.png

0 Likes
BeCo_289361
New Contributor

The device manager when using my good board is exactly the same as when using bad board.

0 Likes
SanjeevG_16
Employee

Hi BeCo_289361​,

For KP3, the HID mode is indicated by breathing LED2 (at 1Hz). For KP2 HID, LED2 will not be lit.

I can see the drivers remain the same. Thanks for confirmation.

Further debugging:

So, in KP3, there are three modes present - CMSIS-DAP BULK, CMSIS-DAP HID and an other mode called DAP-LINK. the DAP-LINK is a custom application downloaded into the KitProg.

In KP2, only two modes present in which one of them is in HID. But when you try to transition from KP3 to KP2, the custom application DAP-LINK is unaffected. If you have downgraded your kit to KP2, you can switch to DAP-LINK by pressing SW4.

Now, I want you to do two things,

First, when in KP3 - Try the command fw-loader --mode kp3-daplink on the command line. Then try downloading  the application.

Second, when in KP2, Press the switch SW4. Now, try downloading the FW and let me know if any of the two steps work.

-73.

0 Likes
BeCo_289361
New Contributor

kitProg3:

fw-loader --mode kp3-daplink

pastedImage_0.png

pastedImage_1.png

kitProg2:

press sw4 once = led 4 lit, led2 breathing.

pastedImage_0.png

pastedImage_1.png

0 Likes
AditiB_81
Moderator
Moderator

Hi,

You can try programming your WICED application with Kitprog2 CMSIS-DAP HID mode. I downgraded to Kitprog2 from Kitprog3 using fw-loader and I can successfully build the code. You can try the following steps to build your application successfully.

Following your sequence of steps:

--> Upgraded to Kitprog3 using fw-loader for MODUS applications.

pastedImage_0.png

-->Downgraded to kitprog2 using fw-loader for WICED applications.

pastedImage_1.png

--> Change to Kitprog2 CMSIS-DAP HID mode for building WICED applications by pressing SW3. After this check for the mode through fw-loader using the command fw-loader --device-list. Only LED4 will be lit on the board.

pastedImage_5.png

--> Build your application in WICED. I am attaching the build log and openocd.txt files.

Thanks

0 Likes
BeCo_289361
New Contributor

AditiB_81,

After studying your output I noticed my fw-loader version was different. I upgraded to version 2.3.0.568 which is the same as yours.

I switched to kp3 and back to kp2. Pressed SW3 until LED4 was the only one lit.

pastedImage_0.png

I then tried to download and got the same results as before. See attached log. I deleted the log so what is in the log is from a single try.

0 Likes
SanjeevG_16
Employee

Hi  BeCo_289361​,

Sorry about the time taken to find the solution. I still am figuring out what is the issue. Can you answer this question: When you try to switch to KitProg2 HID or KitProg3 DAPLINK, do you see the kit as a mass storage device (seperate drive eg:(D:)) on the PC?

-73

BeCo_289361
New Contributor

SanjeevG_16,

Simple answer is yes.

Details:

kp2 -- LED4 is the only one lit.

pastedImage_0.png

pastedImage_1.png

kp3 -- LED2 is strobing. LED4 is on solid.

pastedImage_2.png

pastedImage_3.png

0 Likes
AditiB_81
Moderator
Moderator

Hi,

I have gone through your openocd log file and I see that it throws the error of  "Target not examined, reset NOT asserted!" . Could you please share three .cfg files of WICED? These are:

-->psoc62_gdb_jtag.cfg

-->psoc62-flash-app.cfg

-->psoc62.cfg

Location in WICED:  ./tools/OpenOCD

Thanks

0 Likes
BeCo_289361
New Contributor

AditiB_81

I did a fresh install to see if that would magically fix this. It didn't. The problem is still exactly the same.

Attached are the files you asked for.

I now own five of the kits. Two are in this unusable state. The interesting thing is that the two that don't work are in the hands of two different people. I have one. My employee who lives in another state has the other. We both ended up in this mess on our own without consulting the other.

0 Likes
BeCo_289361
New Contributor

One more thing. When I did the reinstall I came across this:

Note 1: The config.eml file needed for the installation process (must reside in same physical folder as installer during install process) is included as an attachment at the bottom of this page. The config.eml file was not included in the same .zip file as the installer . (as done with previous SDK releases).

There was no config.eml file at the bottom of the page. And there was a config.eml file with the *.exe installer. I proceeded with the install.

0 Likes
xuch_4839286
New Contributor

Hi, I have the similar problem.

pastedImage_3.png

And in my openocd_log

Open On-Chip Debugger 0.10.0+dev-00227-g0d15c62 (2018-03-27-15:19)

Licensed under GNU GPL v2

For bug reports, read

http://openocd.org/doc/doxygen/bugs.html

Info : auto-selecting first available session transport "swd". To override use 'transport select <transport>'.

adapter speed: 1000 kHz

cortex_m reset_config sysresetreq

cortex_m reset_config vectreset

post_init_psoc6_setup

Error: unable to open CMSIS-DAP device 0x4b4:0xf148

But in PSoC Programmer, it is CMSIS-DAP

pastedImage_6.png

May I know the demo you run to get the openocd_log and buildlog?

Thanks

0 Likes
AditiB_81
Moderator
Moderator

Hi,

Please create a new thread for your query. We'll be more than happy to help you there.

Thanks

Aditi

0 Likes
WiWi_4702256
Contributor II

Try this...

https://www.cypress.com/products/psoc-programming-solutions

Make sure you have downloaded latest  PSoC Programmer 3.28.7 if you haven't already

Reflash with --update-kp2

Then start your PSoC Programmer 3.28.7

When you get

pastedImage_0.png

Click "OK" then just click "Load from device" that should put you back where you need to be

BeCo_289361
New Contributor

I did as you suggested. After pressing "Load from device" this is what I get:

pastedImage_0.png

Result of Make Target:

pastedImage_1.png

0 Likes
WiWi_4702256
Contributor II

kitprog2.jpg

Notice that my versions are much newer than yours. Just wondering, do you now get just led4 lit instead of led4 lit and led2 breathing?

0 Likes
WiWi_4702256
Contributor II

ModusToolbox ver. 2.1.0

fw-loader ver.2.3.0.568

Windows Version? if its Windows 7 I know exactly what your issue is!

0 Likes
WiWi_4702256
Contributor II

Even if your windows version is not Windows 7 you may still have the wrong driver installed. I was only able to get WICED working by switching back to kitprog2 and installing the WICED-uart driver that comes with WICED 6.4.0.61.

Did you follow the instuctions about setting up C:\TEMP etc, etc?

wiced_driver.jpg

0 Likes
BeCo_289361
New Contributor

Me:

win 10

modus 2.1.0

wided 6.4.0.61 - have installed several times

fw-loader 2.3.0.568

Yes I did set up C:\TEMP etc, etc.

How do I install WICED-uart driver that comes with WICED 6.4.0.61?

0 Likes
WiWi_4702256
Contributor II

OpenOCD Failed, CY8CKIT-WiFi-BT Pioneer Kit

You may want to follow this thread... I added some of my trials and tribulations...

(note: I am using Windows 7 Pro so it may differ but should be very similar under Windows 10)

In Windows 10; click "search" icon, in search type "device installation settings"

click "no"; save

go to device manager select the port, make sure the device is plugged in and in correct mode... or at least the Programmer states it is in dap mode, the devkit may have led2 and led4 lit and steady, that is the mode I performed the steps in, afterwards, I got the correct indication from the dev kit of led4 lit and no other led's were lit. That is correct mode to program with WICED...

Portable_Devices.jpg

Right click and select update driver and select browse my computer

BrowseMyComputer.jpgLetMePick.jpg

Then let me pick, untick "show compatible hardware"; select Cypress; select Wiced Peripheral UART

SelectWicedDriverUart.jpg

Select "have disk"

Navigate to C:(where ever you have WICED installed..)\WICED-Studio-6.4\Drivers\Windows\wiced_uart

Select wicedport.inf

wicedport.jpg

Let that install...

Now it may Let you know "installing new device" or not, it not unplug DevKit and plug it back in. Make SURE that you did these steps!!!:

In Windows 10; click "search" icon, in search type "device installation settings"; click "no"; save

Anyway you will see the "installing new device" then, go to device manager, your goal is to see the kitProg2 device under Portable Devices"

Portable_Devices.jpg

Here is what I think happened, you had it installed properly, when you powered off and back on Windows 10 in its infinite wisdom installed the driver that "it" thought was best. I read an article about that, I've read so many articles, I could not re-reference it... But they were only speaking about Windows 7 which, I've never had as much issues with, as I have with Windows 10!!! which "they" shoved down our throats imho... Oh... uh I guess that is not nice

View solution in original post

WiWi_4702256
Contributor II

Hey BeCo_289361,

This issue has not been marked answered... If it was resolved, then please let me know what it was... Thanks!

If not, I was looking over this again, some statements you made got my attention...

First:

item1.jpg

You stated:

"There was not config.eml file at the bottom of the page. And there was a config.eml file with the *.exe installer. I proceeded with the install"

Second:

item2.jpg

You did the install as you point out, BUT, I believe it was done with a previous SDK release based on previous statement above.

Please reference WICED-Studio 6.4.0 Installer (Windows)

Scroll all the way to bottom, click and download: config.eml, README_WINDOWS.txt.zip, and WICED-Studio-6.4.0.61-IDE-Installer.exe.zip

The WICED-Studio-6.4.0.61-IDE-Installer.exe.zip will NOT contain config.eml, this is the correct (latest) version...

As pointed out in the link I provided ( WICED-Studio 6.4.0 Installer (Windows) 😞 I placed the downloaded config.eml and unzipped WICED installer.exe in C:\TEMP

Download_unzip.jpg

Note: the ProxyName.ini was generated during install "5/19/2020 2:40 PM"

place_TEMP.jpg

As you will see when you click on the link I provided ( WICED-Studio 6.4.0 Installer (Windows) ), Michael_56 points out the following:

Note 2:

There is a known installer issue which occurs when white space is included in the path to the temp folder.

To overcome this issue, do the following:

  • Create a folder: c:\temp
  • Open Windows Control Panel->System -> Advanced System Setting -> Environment Variables
  • Edit TEMP and TMP path to use c:\temp

-->In my case, C:\TEMP already existed. So all I did was to make sure it was under System Variable, in my case it was.

If that is not the case with you, then make sure System Variable TEMP value is: %SystemRoot%\TEMP

I did not change TMP to use C:\TEMP

TEMP.jpg

Then double-click on WICED-Studio-6.4.0.61-IDE-Installer.exe in C:\TEMP to install...

I recommend the following in the order stated:

  • Use Programmer to reflash to KitProg2 with --update-kp2
  • Reinstall your WICED Driver: \WICED-Studio-6.4\Drivers\Windows\wiced_uart\wicedport.inf
  • Rebuild and "hopefully" finally... flash your application!

See if this helps...