cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

user_2199751
New Contributor

Hi

I have an issue which I have been struggling to resolve for a couple of months. Please see below issue and wish to hear some advices from other experts.

TCP Socket disconnection Issue

-WiFi Module : BCM4390 SPIL module (SB–WM-N03)

-SW version and platform: BCM94390WCD2 in the WICED 3.1.2 SDK

-TCP Stack: NetX_duo

-Issue details: Our device with wifi module transfers 1023byte data in every 220ms to the control tablet (Android based OS). During the transmission,  TCP socket failure happens and data transmission stops. When the TCP socket is disconnected, device and Tablet wifi connection is still alive by checking with ping.

   As we checked the log from the wifi module, we observed "wiced_tcp_send_buffer fail!!! –1" message.  We could not get the tcp dump from the platform since it is MCU based embedded system but we could capture wifi log and could check the TCP signaling. From the various WiFi logs, we observed transmit stoppage happened for about more than 3 seconds and as a result, TCP stack ended up reseting the connection.

-Frequency of the issue: The issue happened in normal office environment.  When it happens, it happens once in one or two hours. 

-Opinion on the issue: We suspect that somehow the WiFi module behaves strangely on that specific moments and loses packets; as a result, the TCP stack is disconnected. We can make the SW reconnect when the disconnection happens; however, we can not stop losing the data which is very important in our application.  This instability issue is very serious to our project and hope to find a solution or work around not to lose the packets.

Device wifi Mac: B2:38:29:21:2d:5c  (IP: 192.168.0.1)

Tablet WiFi Mac: 94:76:B7:a7:15:75 (IP: 192.168.0.2)

Wifi Security: Tested in open mode.

pastedImage_0.png

pastedImage_6.png

pastedImage_7.png

0 Likes
1 Solution
GauravS_31
Moderator
Moderator

Do you observe this issue in WICED SDK 3.7.0-7?

View solution in original post

0 Likes
3 Replies
GauravS_31
Moderator
Moderator

Do you observe this issue in WICED SDK 3.7.0-7?

View solution in original post

0 Likes
user_2199751
New Contributor

In 3.7.0-7, we could not make the soft AP work and therefore we could not try this.

0 Likes
GauravS_31
Moderator
Moderator

Could you check with snip.apsta if the softAP is brought up? If it fails, check the return value of wiced_network_up(WICED_AP_INTERFACE, WICED_USE_INTERNAL_DHCP_SERVER, &ap_ip_settings);

0 Likes