cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Wi-Fi Combo

New Contributor II

Hello

I have a question about how to debug OTA2.
When I try to debug OTA2 using the sample code, there are places where it doesn't work.

(1) When debugging, breakpoints cannot be executed with boot loader related code.
This is because the boot loader processing has already been completed.
Please tell me how to set up Wiced to debug the boot loader.

(2) Currently "apps \ waf \ bootloader" is the build target.
Please tell me how to change "apps \ waf \ ota2_bootloader" to a build target.

Thank you

0 Likes
Reply
1 Solution
Moderator
Moderator

if you are using a debug mode, refer this link  to make your board run a good debug mode.

Re: Problem with Debugging

then I am using 4343WWCD2 to have a debug.

1.  check the debug mode.

snip.scan-BCM94343WWCD2-debug download

2. then use below command to debug bootloader step by step:

waf.bootloader-NoOS-BCM94343WWCD2

check this pic to have a reference.

pastedImage_1.png

View solution in original post

2 Replies
Moderator
Moderator

if you are using a debug mode, refer this link  to make your board run a good debug mode.

Re: Problem with Debugging

then I am using 4343WWCD2 to have a debug.

1.  check the debug mode.

snip.scan-BCM94343WWCD2-debug download

2. then use below command to debug bootloader step by step:

waf.bootloader-NoOS-BCM94343WWCD2

check this pic to have a reference.

pastedImage_1.png

View solution in original post

New Contributor II

Thank you.

I was saved.

0 Likes
Reply