cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

ns_4270701
New Contributor II

Hello Sir/Madam,

   We have designed our own customized PCB board using CYBT-423028-02 module. A screenshot of a schematic is attached here.

Development environment:

Windows 8.1 pro

Platform: CYBT-423028-02 (Module)

IDE: Wiced Studio 6.2.1

Hardware: Customized hardware board using CYBT-423028-02 module

Also followed the steps suggested in this link: WICED Studio: Platform Files for CYBT-423028-EVAL - KBA223637

We are facing to program a CYBT-423028-02 module using USB-UART bridge.

Please note we have followed the hardware setup and connection as suggested in below link.

Programming an EZ-BT WICED Module – KBA223428

And tried to load an application to the module, got the output in a console as attached here.

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator

Did you try to program in the recover mode:

1. Pull the UART_CTS to GND

2. Power cycle the device

3. Release the UART_CTS pin

Then program it again.

You may also use the module programmer: WICED Module Programmer User Guide – KBA225060

View solution in original post

8 Replies
Owen_Zhang123
Moderator
Moderator

Did you try to program in the recover mode:

1. Pull the UART_CTS to GND

2. Power cycle the device

3. Release the UART_CTS pin

Then program it again.

You may also use the module programmer: WICED Module Programmer User Guide – KBA225060

View solution in original post

ns_4270701
New Contributor II

Thank you for your response, OwenZ_26.

Did you try to program in the recover mode:

1. Pull the UART_CTS to GND

2. Power cycle the device

3. Release the UART_CTS pin

Then program it again.

Yes, we did that. But not succeded.

You may also use the module programmer: https://community.cypress.com/docs/DOC-15775

We had used it as well. please see the below log.

                                        • Log from WICED Module programmer *********************

24-09-2019 12:32:30.325: LogManager: Started

24-09-2019 12:32:31.064: WICEDModuleProg: Module Family: CYW20719_SFlash

24-09-2019 12:32:31.083: WICEDModuleProg: Module Family: CYW20719_SFlash

24-09-2019 12:32:31.113: WICEDModuleProg: Programming Board: UART Adapter Board

24-09-2019 12:32:31.113: WICEDModuleProg: Initialization complete

24-09-2019 12:32:31.624: ProgramManager: NewConfig1 - program created.

24-09-2019 12:32:31.626: WICEDModuleProg: Default test program created.

24-09-2019 12:32:37.612: PortSetDlg[42]COM1DUTClosed: 2 serial ports found.

24-09-2019 12:32:41.688: PortSetDlg[42]COM1DUTClosed: 2 serial ports found. 24-09-2019 12:32:53.917: PortSetDlg[42]COM3DUT: Connected to "COM3 - Silicon Labs CP210x USB to UART Bridge (COM3)" (115200, None) 24-09-2019 12:32:58.015: ProgramManager: Selecting_DUT 1/8

24-09-2019 12:32:58.157: ProgramManager: Selecting_DUT 2/8

24-09-2019 12:32:58.176: ProgramManager: Selecting_DUT 3/8

24-09-2019 12:32:58.193: ProgramManager: Selecting_DUT 4/8

24-09-2019 12:32:58.209: ProgramManager: Selecting_DUT 5/8

24-09-2019 12:32:58.216: ProgramManager: Selecting_DUT 6/8

24-09-2019 12:32:58.254: ProgramManager: Selecting_DUT 7/8

24-09-2019 12:32:58.269: ProgramManager: Selecting_DUT 8/8

24-09-2019 12:32:58.387: WICEDModuleProg: Test program stopped.

24-09-2019 12:34:10.306: ProgramManager: Selecting_DUT 1/8 24-09-2019 12:34:11.758: Prog[0]COM3 : Reset (COM3) Timeout! 24-09-2019 12:34:11.761: Prog[0]COM3 : Soft-Reset Fail COM3

24-09-2019 12:34:11.763: Prog[0]COM3 : Failed to reset on baudrate = 115200

24-09-2019 12:34:11.766: Prog[0]COM3 : Failed to reset DUT

24-09-2019 12:34:11.780: ProgramManager: -


>SetResult  = TestFailed 24-09-2019 12:34:11.836: ProgramManager: Selecting_DUT 2/8

24-09-2019 12:34:11.903: ProgramManager: Selecting_DUT 3/8

24-09-2019 12:34:11.967: ProgramManager: Selecting_DUT 4/8

24-09-2019 12:34:12.018: ProgramManager: Selecting_DUT 5/8

24-09-2019 12:34:12.068: ProgramManager: Selecting_DUT 6/8

24-09-2019 12:34:12.128: ProgramManager: Selecting_DUT 7/8

24-09-2019 12:34:12.187: ProgramManager: Selecting_DUT 8/8

24-09-2019 12:34:12.334: WICEDModuleProg: Test program stopped.

Regards,

Namita Shah | Embedded Developer

0 Likes
BoonT_56
Employee

In the wiced programmer, did you select baud rate as 115200 with flow control?

I had success with a 20719 eval board and the wiced module programmer.

25-09-2019 14:02:00.723: LogManager: Started

25-09-2019 14:02:01.334: WICEDModuleProg: Module Family: CYW20719_SFlash

25-09-2019 14:02:01.360: WICEDModuleProg: Module Family: CYW20719_SFlash

25-09-2019 14:02:01.371: WICEDModuleProg: Programming Board: UART Adapter Board

25-09-2019 14:02:01.371: WICEDModuleProg: Initialization complete

25-09-2019 14:02:01.445: ProgramManager: NewConfig1 - program created.

25-09-2019 14:02:01.447: WICEDModuleProg: Default test program created.

25-09-2019 14:02:01.529: PortSetDlg[40]COM5DUT: Connected to "COM5 - WICED HCI UART (COM5)" (115200, RequestToSend)

25-09-2019 14:02:25.374: ProgramManager: Selecting_DUT 1/8

25-09-2019 14:02:36.638: Prog[0]COM5 : Download complete. (11167.0981ms)

25-09-2019 14:02:44.813: ProgramManager: Selecting_DUT 2/8

25-09-2019 14:02:44.891: ProgramManager: Selecting_DUT 3/8

25-09-2019 14:02:44.964: ProgramManager: Selecting_DUT 4/8

25-09-2019 14:02:45.027: ProgramManager: Selecting_DUT 5/8

25-09-2019 14:02:45.174: ProgramManager: Selecting_DUT 6/8

25-09-2019 14:02:45.250: ProgramManager: Selecting_DUT 7/8

25-09-2019 14:02:45.301: ProgramManager: Selecting_DUT 8/8

25-09-2019 14:02:45.526: WICEDModuleProg: Test program stopped.

25-09-2019 14:03:08.361: PortSetDlg[42]COM5DUT: 2 serial ports found.

ns_4270701
New Contributor II

In the wiced programmer, did you select baud rate as 115200 with flow control?

I had success with a 20719 eval board and the wiced module programmer.

Yes, we did so.

What we tried for:

1. Pull the UART_CTS to GND

2. Power cycle the device

3. Release the UART_CTS pin

Then programing

- Even we tried with flow control enable and flow control disable.

- Tried with different baud rate as well.

Just to make sure there are no config issues.

                                        • Log from WICED Module programmer *********************

25-09-2019 11:38:34.580: PortSetDlg[42]COM3DUT: Connected to "COM3 - Silicon Labs CP210x USB to UART Bridge (COM3)" (115200, RequestToSend)

25-09-2019 11:38:36.397: ProgramManager: Selecting_DUT 1/8

25-09-2019 11:38:37.792: Prog[7]COM3 : Reset (COM3) Timeout!

25-09-2019 11:38:37.796: Prog[7]COM3 : Soft-Reset Fail COM3

25-09-2019 11:38:37.798: Prog[7]COM3 : Failed to reset on baudrate = 115200

25-09-2019 11:38:37.800: Prog[7]COM3 : Failed to reset DUT

25-09-2019 11:38:37.811: ProgramManager: -


>SetResult  = TestFailed

25-09-2019 11:38:37.867: ProgramManager: Selecting_DUT 2/8

25-09-2019 11:38:37.932: ProgramManager: Selecting_DUT 3/8

25-09-2019 11:38:37.996: ProgramManager: Selecting_DUT 4/8

25-09-2019 11:38:38.052: ProgramManager: Selecting_DUT 5/8

25-09-2019 11:38:38.113: ProgramManager: Selecting_DUT 6/8

25-09-2019 11:38:38.168: ProgramManager: Selecting_DUT 7/8

25-09-2019 11:38:38.232: ProgramManager: Selecting_DUT 8/8

25-09-2019 11:38:38.397: WICEDModuleProg: Test program stopped.

25-09-2019 11:38:40.827: PortSetDlg[42]COM3DUT: 2 serial ports found.

25-09-2019 11:38:45.935: PortSetDlg[42]COM3DUT: Connected to "COM3 - Silicon Labs CP210x USB to UART Bridge (COM3)" (1000000, RequestToSend)

25-09-2019 11:38:48.232: ProgramManager: Selecting_DUT 1/8

25-09-2019 11:38:49.626: Prog[7]COM3 : Reset (COM3) Timeout!

25-09-2019 11:38:49.629: Prog[7]COM3 : Soft-Reset Fail COM3

25-09-2019 11:38:49.632: Prog[7]COM3 : Failed to reset on baudrate = 1000000

25-09-2019 11:38:49.637: Prog[7]COM3 : Failed to reset DUT

25-09-2019 11:38:49.649: ProgramManager: -


>SetResult  = TestFailed

25-09-2019 11:38:49.706: ProgramManager: Selecting_DUT 2/8

25-09-2019 11:38:49.756: ProgramManager: Selecting_DUT 3/8

25-09-2019 11:38:49.808: ProgramManager: Selecting_DUT 4/8

25-09-2019 11:38:49.861: ProgramManager: Selecting_DUT 5/8

25-09-2019 11:38:49.927: ProgramManager: Selecting_DUT 6/8

25-09-2019 11:38:49.987: ProgramManager: Selecting_DUT 7/8

25-09-2019 11:38:50.046: ProgramManager: Selecting_DUT 8/8

25-09-2019 11:38:50.229: WICEDModuleProg: Test program stopped.

25-09-2019 11:39:21.250: ProgramManager: Selecting_DUT 1/8

25-09-2019 11:39:23.114: Prog[7]COM3 : Reset (COM3) Timeout!

25-09-2019 11:39:23.116: Prog[7]COM3 : Soft-Reset Fail COM3

25-09-2019 11:39:23.118: Prog[7]COM3 : Failed to reset on baudrate = 1000000

25-09-2019 11:39:23.120: Prog[7]COM3 : Failed to reset DUT

25-09-2019 11:39:23.129: ProgramManager: -


>SetResult  = TestFailed

25-09-2019 11:39:23.190: ProgramManager: Selecting_DUT 2/8

25-09-2019 11:39:23.256: ProgramManager: Selecting_DUT 3/8

25-09-2019 11:39:23.309: ProgramManager: Selecting_DUT 4/8

25-09-2019 11:39:23.361: ProgramManager: Selecting_DUT 5/8

25-09-2019 11:39:23.415: ProgramManager: Selecting_DUT 6/8

25-09-2019 11:39:23.478: ProgramManager: Selecting_DUT 7/8

25-09-2019 11:39:23.529: ProgramManager: Selecting_DUT 8/8

25-09-2019 11:39:23.677: WICEDModuleProg: Test program stopped.

25-09-2019 11:39:46.676: WICEDModuleProg: Editing preferences.

25-09-2019 11:40:04.239: ProgramManager: Loading config file.

25-09-2019 11:40:08.014: ProgramManager: Test program load cancelled.

25-09-2019 11:42:05.680: PortSetDlg[42]COM3DUT: 2 serial ports found.

Please note that we have CYW920719Q40EVB-01 board and tested some example codes with it.

Everything working properly with the EV board.

Our issue is with 423028 module only, We have designed a custom board for CYBT-423028-02 module.

Schematic part attached/below here.

Please check is our connection proper as it should be.

The reset pin connection?

Regards,

Namita Shah | Embedded Developer

0 Likes
BoonT_56
Employee

From your attachment, I do see a concern with XRES. In short, there should be some circuitry at XRES to pull it to LOW for at least 50ms while the Vcc voltage stabilized. This information was on pg12 of the 423028 datasheet. You may try a workaround, remove R1, and replace C14 with a 0.33uF capacitor. Please refer to the said section for a better explanation.

0 Likes
ns_4270701
New Contributor II

From your attachment, I do see a concern with XRES. In short, there should be some circuitry at XRES to pull it to LOW for at least 50ms while the Vcc voltage stabilized. This information was on pg12 of the 423028 datasheet. You may try a workaround, remove R1, and replace C14 with a 0.33uF capacitor. Please refer to the said section for a better explanation.

Yes did that. we have removed R1 and replaced C14 with 1uF(As in that section mentioned that 0.33uF is not strict value to follow)

XRES to pull it to LOW for at least 50ms while the Vcc voltage stabilized

Yes, we had not kept any switch on board as our requirement for PCB size is very small. So we could not make a room for switch or any extra part.

So we are managing pulling the XRES and CTS pin low externally. We also checked on CRO for confirming timings for a low signal on both the pins.

Regards,

Namita Shah | Embedded Developer

0 Likes
BoonT_56
Employee

You may want to consider another method:

Add VERBOSE=1 before "download" to your make target, recompile and download. You will see a lot of details and

towards the end, you will see the execution of "Chipload.exe" to download your app onto the board. Take note of this

rather long command.

In your wiced project folder,

1) Copy Chipload.exe in wiced_tools to a temp folder in C:\

2) Copy the xxx-release.hex file in the build folder to the temp folder

3) Copy the aaa-uart.hex file file in platforms folder to the temp folder

Open the command prompt and point to the temp folder. Execute the following:

ChipLoad.exe -BLUETOOLMODE -PORT COM5 -BAUDRATE AUTO -NOHCIRESET  -NOVERIFY -CHECKCRC -MINIDRIVER minidriver-20739A0-uart.hex -BTP 20719_OCF.btp -CONFIG hello_sensor-CYW920719Q40EVB_01-rom-ram-Wiced-release.hex

ns_4270701
New Contributor II

Thank you,

we have changed our hardware board, In old board, we found some power issue.

Now, it is done and working properly.