cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

JoJo_2624151
New Contributor II

I directly compile the WICED6.2 "MeshAPP" source code.There was an error when "build APK" was prompted. The attachment is the LOG information. Please help to check it

0 Likes
Reply
1 Solution
AnjanaM_61
Moderator
Moderator

Hi ,

We fixed this issue and will be available in next release (This issue is caused due to studio update to 3.2)

For now, for the error which you are facing please delete the below files and rebuild your app (These files doesn’t build with the latest studio version and they shouldn’t be in the framework )

common/apps/snip/mesh/peerapps/Android/src/MeshApp/meshframework/libs/aws-android-sdk-core-2.2.6.jar

common/apps/snip/mesh/peerapps/Android/src/MeshApp/meshframework/libs/awsiotdata.jar

I have attached the gradle and NDK version which we are using , can you please update to the same ? ( please bring down your ndk version to 17.0.4 )

Thanks,

Anjana

View solution in original post

5 Replies
AnjanaM_61
Moderator
Moderator

Hi,

Which is the Android studio version?

0 Likes
Reply
JoJo_2624151
New Contributor II

Android studio 3.2

0 Likes
Reply
DheerajK_81
Moderator
Moderator

When you built the project, did you click on any prompt to upgrade the gradle, compilesdk or ndk versions? Please let me know if you made any changes to the project and also the steps to recreate the error.

Regards,

Dheeraj

AnjanaM_61
Moderator
Moderator

Hi ,

We fixed this issue and will be available in next release (This issue is caused due to studio update to 3.2)

For now, for the error which you are facing please delete the below files and rebuild your app (These files doesn’t build with the latest studio version and they shouldn’t be in the framework )

common/apps/snip/mesh/peerapps/Android/src/MeshApp/meshframework/libs/aws-android-sdk-core-2.2.6.jar

common/apps/snip/mesh/peerapps/Android/src/MeshApp/meshframework/libs/awsiotdata.jar

I have attached the gradle and NDK version which we are using , can you please update to the same ? ( please bring down your ndk version to 17.0.4 )

Thanks,

Anjana

View solution in original post

JoJo_2624151
New Contributor II

Hi

Thank you.Let me test that out

0 Likes
Reply