cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

oxz1918
New Contributor II

Hi, 

I want test the Accept/End incoming call/ongoing call with CYBT_343026_EVAL , I use headset sample in WICED-Studio-6.4.

 Uncomment the C_FLAGS += -DSTANDALONE_HEADSET_APP flag in makefile.mk and  program the board from WICED SDK using Make Target:  demo.audio.headset-CYBT_343026_EVAL BT_DEVICE_ADDRESS=random download UART=COM11. 

Then I use ClientControl, select HCI COM port, Baudrate as 115200 and click on Open port,  the Client Control app: the serial port is open, but options/buttons don't become availablebut. No device discoverable through a bluetooth scanner. Could you help me to check it?  Thank you in advance!

0 Likes
1 Solution
Owen_Zhang123
Moderator
Moderator

I test WICED 6.4 and get the same problem as you. 

I also test WICED 6.2 and it works well. Please try the WICED 6.2.

Also, the default HCI UART baudrate in the application is 3000000, you need to set it to 3000000 in the client control.

If you want to use Modus Tool Box, the headset demo is not supported by the CYBT-343026 platform now. You need to use the CYW20706 platform and change the hardware configuration.

View solution in original post

0 Likes
9 Replies
Owen_Zhang123
Moderator
Moderator

Did you install the platform files for the module? If you are using WICED 6.4, you need to make some change in the demo code because the name of the platform files are different. You can use the Modus Tool Box for your development which is the latest SDK. You may also use WICED 6.2 and install the platform files as the KBA says:

https://community.cypress.com/t5/Knowledge-Base-Articles/Platform-Files-for-CYBT-343026-EVAL-KBA2210...

You can get the WICED 6.2.1 here:

https://www.cypress.com/documentation/software-and-drivers-archive/wiced-studio-archive

 

After you download the application and open the clientcontrol tool, please try to reset the board first to see if the options are available.

0 Likes
oxz1918
New Contributor II

Yes , I have install the platform files for  the module in WICED 6.4. I also make the follow changes:

1. In Headset sample makefile , add "APP_PATCHES_AND_LIBS += FM25Q04_sflash.a"

2. CYBT_343026_EVAL/platform.c , modify  include file to  #include "wiced_platform.h"

3. Rename the  wiced_hal_platform.h  to wiced_platform.h

The WICED 6.4 SDK can't work ,  should I use WICED 6.2.1 or Modus Tool Box?

 

0 Likes
Owen_Zhang123
Moderator
Moderator

I will test it on WICED 6.4 to see if there is any problem.

0 Likes
Owen_Zhang123
Moderator
Moderator

I test WICED 6.4 and get the same problem as you. 

I also test WICED 6.2 and it works well. Please try the WICED 6.2.

Also, the default HCI UART baudrate in the application is 3000000, you need to set it to 3000000 in the client control.

If you want to use Modus Tool Box, the headset demo is not supported by the CYBT-343026 platform now. You need to use the CYW20706 platform and change the hardware configuration.

View solution in original post

0 Likes
oxz1918
New Contributor II

Thank you for your reply . I have tested the WICED 6.2, Headset sample works well . I connect the CYBT_343026_EVAL with a audio board by I2S,  then I connect my mobile phone with the CYBT_343026 by bluetooth,  and play music, I can hear the voice  clear.

But when I make a call , there is no voice from the microphone.

Is it  normal for this scenario?

0 Likes
Owen_Zhang123
Moderator
Moderator

"But when I make a call , there is no voice from the microphone."
Do you mean you can't hear the voice in the headset? It is abnormal for this scenario.

0 Likes
oxz1918
New Contributor II

Yes,  I can't hear the voice in the headset.  The hardware connect is the same as the A2DP Sink Example on CYW20706 - Cypress Developer Community.   But the app is headset sample. 

I can hear the voice when the phone play music , but When I make a call ,it is no voice from the microphone,  could you help me to look into this issue?  Thank you very much!

0 Likes
Owen_Zhang123
Moderator
Moderator

Could you share some logs during the test? I have tested the demo and the voice is normal on the headset side.

0 Likes
oxz1918
New Contributor II

Thank you for you reply. I change GPIO setting ,  both A2DP and HFP works well. Thanks again.

0 Likes