cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

igloc_3085191
New Contributor II

Hi all,

I have recently acquired 3 CYBT-343026-EVAL kits. I have tried to flash all three evaluation kits without any sucess.

I have strictly follow the following programming guide:

Programming an EZ-BT WICED Module – KBA223428  (including the ref document Platform Files for CYBT-343026-EVAL – KBA221025 )

I am programming using the v6.2 of the WICED Studio and I've got the following error:

pastedImage_4.png

If I follow the first todo list, only the red D3 led will remain on.

If I follow the second todo list, both the red D3 and green D2 will flash.

In both cases I will get the above error. I've got the same for all 3 kits. They all 3 are new unflashed out from the box.

Any help most welcome

0 Likes
Reply
3 Replies
Owen_Zhang123
Moderator
Moderator

It seems that the device can be found but the program is failed.

Could you share the log files: download.log and logto.log for us. The files are located in folder WICED-Studio-6.2\20706-A2_Bluetooth\build\hello_sensor-CYW920706WCDEVAL-rom-ram-Wiced-release if you program the hello_sensor project for example.

0 Likes
Reply
igloc_3085191
New Contributor II

Hi,

Sorry for the late response as I was away. I can manage to program the hello_sensor.

The problem is that my own application will not program the CYBT-343026-EVAL kit. I can manage to program a CYBT-343026-01 module with a serial cable but not the evaluation kit. I want to use the evaluation kit for debugging purposes as it has by default the uart already wired.

I have attached logs for both the hello_senor succcessfull programming and my own code failed programming. I suppose the main difference in the code is that I am using SPI on mhy own code.

Any hint most welocme

Thanks

Ignacio

0 Likes
Reply
Owen_Zhang123
Moderator
Moderator

ignacio.lopez_3085191

I am not quite clear about the situation. Is that you can program the application successfully to the CYBT-343026-01 module with a serial cable, but it will fail when you program the same application to the CYBT-343026-EVAL kit. That's very unreasonable. Have you tried to proram the kit board with a serial cable through the HCI UART(J1)?

0 Likes
Reply