cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

GlGr_3997396
New Contributor II

We've been doing field tests with our custom PCB containing the CYBT-413034-02 module. In these field tests we are noticing a certain directionality with the antenna. In order to understand how the current setup is behaving we've sent our product to a test lab to measure the antenna power per direction. In order to do this they require a 'Clean Carrier Wave' signal. Which is a non modulated carrier wave. I have been researching some documentation but so far I have only been able to find the Bluetooth Tx Testmode which is modulated.

Can someone please advise if this mode exists on the CYBT-413034-02 and if so, how to enable it?

0 Likes
1 Solution
SheetalJ
Moderator
Moderator

The commend output shows success and correct response event. However, I am doubtful if you have sent the correct command. You can get detailed command description in the attached document. Also, please check following posts:

Running BlueZ on CY Part

CyBlueTool not activating transmit test correctly on 413034 module

RF Testing on Cypress BT Devices - KBA228303

Re: CYBT-413034-02: "LE Set Scan Parameters Command" returns "COMMAND DISALLOWED (0x0C)"

View solution in original post

0 Likes
4 Replies
SheetalJ
Moderator
Moderator

Hi GlGr_3997396​,

Can you please go through the attached doc & see if it helps?

GlGr_3997396
New Contributor II

Hi SheetalJ_96​,

This seems like a good first step. I think the 'Set_Tx_Carrier_Frequency_ARM' might be what I am looking for.

However, our product runs embedded Linux so there is no way for me to use CyBluetool. I have tried to decode the HCI command CyBluetool sends. Since it is a vendor specific command BlueZ is also unable to decode the command. I have put the output below, can you confirm I have decoded it properly?

Command:
hcitool -i hci0 cmd 0x3f 0x0014 0x00 0x02 0x00 0x00 0x08 0x04 0x00

< HCI Command: ogf 0x3f, ocf 0x0014, plen 7

  00 02 00 00 08 04 00

> HCI Event: 0x0e plen 4

  01 14 FC 00

btmon output:

< HCI Command: Vendor (0x3f|0x0014) plen 7  

        00 02 00 00 08 04 00                

> HCI Event: Command Complete (0x0e) plen 4 

      Vendor (0x3f|0x0014) ncmd 1

        Status: Success (0x00)

0 Likes
SheetalJ
Moderator
Moderator

The commend output shows success and correct response event. However, I am doubtful if you have sent the correct command. You can get detailed command description in the attached document. Also, please check following posts:

Running BlueZ on CY Part

CyBlueTool not activating transmit test correctly on 413034 module

RF Testing on Cypress BT Devices - KBA228303

Re: CYBT-413034-02: "LE Set Scan Parameters Command" returns "COMMAND DISALLOWED (0x0C)"

View solution in original post

0 Likes
GlGr_3997396
New Contributor II

Hi SheetalJ_96​,

The command seems correct. I have verified on my desk, see below picture. Since I've also received conformation from the lab that they were able to see the signal. Thank you for the help. This thread may be closed.pastedImage_0.png