cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

Anonymous
Not applicable

Greetings,

Although I configured my application to work at 921600 bps, the debug UART (which I routed to the PUART) still works at 115200 bps.

Is the debug UART set to work at this baudrate by default? If so, is it possible to change it?

Thank you.

Best regards.

0 Likes
Reply
1 Solution
LJYe_2922526
Contributor

I think you are searching for wiced_hal_puart_set_baudrate(921600). Another useful one is wiced_hal_puart_flow_off().

I recommend reading wiced_hal_puart.h.

View solution in original post

3 Replies
Anonymous
Not applicable

Are you referring to the PUART or HCI UART? Can you kindly describe how you are configuring the baud rate?

If you are referring to the PUART, then the default baudrate is 115200 bps. You can change the baudrate by making use of wiced_hal_puart_set_baudrate() API.

If you are referring to the HCI UART, then again the default is 115200. The baudrate can be changed in the wiced_transport_cfg_t structure.

Note that CYBT-343026_EVAL supports only upto 1M baudrate on both the UARTs. This is not a limitation of the CYBT-343026 but is limited because of the USB-serial device on the eval board.

0 Likes
Reply
LJYe_2922526
Contributor

I think you are searching for wiced_hal_puart_set_baudrate(921600). Another useful one is wiced_hal_puart_flow_off().

I recommend reading wiced_hal_puart.h.

View solution in original post

Anonymous
Not applicable

That's it!

Thank you very much for your response.

Best regards.

0 Likes
Reply