cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Studio Bluetooth

New Contributor

I'm using CYBT343026 to do an applicaion:A2DP and BLE.

pastedImage_0.png

I use P24 as PUART TX,and P25 as PUART RX.see the picture above.

There is a issue that when it cold start,RX does not work,TX works.After I reset it,both works.

I tried in the demo appplication ‘hal->puart’,it has the same issue.

0 Likes
Reply
5 Replies
Employee

Our engineer has suggested disabling the unused function. The below is somewhat similar to your case. Let me know if it helps.

Could I config WICED_P04 as GPIO with CYW20706?

0 Likes
Reply
New Contributor

That's not my issue. I have already add these.

My issue is :

Power on:P24 RX does not work.

Reset:     P24 RX works.

0 Likes
Reply
New Contributor II

1) In your circuit, what is connected on pin 3 (RESET_N) of the module?

2) Also how you are supplying the power to the module, can you measure the power supply rise time? to the module or just observe on the scope and share observations.

New Contributor

1) In your circuit, what is connected on pin 3 (RESET_N) of the module?

up to v3.3

2) Also how you are supplying the power to the module, can you measure the power supply rise time? to the module or just observe on the scope and share observations.

It is not the power problem.Each time when I download the program,the problem will come out too.

it is easy to reproduce the issue using the sample code in the SDK.

0 Likes
Reply
New Contributor II

Please try to issue a HCI reset command over HCI transport as first thing from Host.

0 Likes
Reply