cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

I have found that iPhone will not re-pair to a device that is still in its bluetooth menu after device calls

lesmpkeys_removeAllBondInfo();

  emconninfo_clearDeviceBondedFlag();

  emconninfo_clearLinkEncryptedFlag();

and then after reconnecting with phone in connection up sends a security request.

Security request is ignored by phone, callback never received on device. Phone stays connected to device but not in bonded/encrypted state (according to  emconninfo_deviceBonded & emconninfo_linkEncrypted flags).

0 Likes
Reply
1 Solution
Anonymous
Not applicable

Hi,

Is the Bonding information stored on the device? If not, please include the same in the device firmware. It might be possible that the pairing information is stored in the phone (by default) and it might not have been stored in the device during the first connection. This mismatch might cause the pairing fail during the second connection.

Or if you remove the device in the Phone's bluetooth list, you might be able to pair again.

Regards,

- Madhu Sudhan

View solution in original post

1 Reply
Anonymous
Not applicable

Hi,

Is the Bonding information stored on the device? If not, please include the same in the device firmware. It might be possible that the pairing information is stored in the phone (by default) and it might not have been stored in the device during the first connection. This mismatch might cause the pairing fail during the second connection.

Or if you remove the device in the Phone's bluetooth list, you might be able to pair again.

Regards,

- Madhu Sudhan

View solution in original post