cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Hi,

have downloaded WICED-Smart-SDK-1.0.1.7z to build and flash in WICED Smart device.

My build environment is:

OS: Ubuntu 12.04 -32bit

Made changes in the Makefile(wiced_toolchain_common.mk) for 32-bit linux.

Downloaded required packages mentioned in /Tools/source/ARM_GNU/README.TXT file and build each one successfully.

To OpenOCD build , Ran build_all.sh script

It is giving me the following error.

.

.

ibtoolize: copying file `m4/ltoptions.m4'

libtoolize: copying file `m4/ltsugar.m4'

libtoolize: copying file `m4/ltversion.m4'

libtoolize: copying file `m4/lt~obsolete.m4'

/usr/share/aclocal/dotconf.m4:5: warning: underquoted definition of AM_PATH_DOTCONF

/usr/share/aclocal/dotconf.m4:5:   run info '(automake)Extending aclocal'

/usr/share/aclocal/dotconf.m4:5:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal

configure.ac:11: warning: LT_INIT was called before AM_PROG_AR

/usr/share/aclocal-1.11/ar-lib.m4:15: AM_PROG_AR is expanded from...

configure.ac:11: the top level

autoreconf: running: /usr/bin/autoconf --force

configure.ac:11: warning: LT_INIT was called before AM_PROG_AR

aclocal.m4:75: AM_PROG_AR is expanded from...

configure.ac:11: the top level

autoreconf: running: /usr/bin/autoheader --force

configure.ac:11: warning: LT_INIT was called before AM_PROG_AR

aclocal.m4:75: AM_PROG_AR is expanded from...

configure.ac:11: the top level

autoreconf: running: automake --add-missing --copy --force-missing

configure.ac:11: warning: LT_INIT was called before AM_PROG_AR

aclocal.m4:75: AM_PROG_AR is expanded from...

configure.ac:11: the top level

configure.ac:11: installing `build-aux/ar-lib'

configure.ac:4: installing `build-aux/missing'

src/Makefile.am: installing `build-aux/depcomp'

autoreconf: Leaving directory `.'

autoreconf done.

Bootstrap complete. Quick build instructions:

./configure ....

HEAD is now at ab939f3 Add floating point support for [binary]

fatal: /usr/lib/git-core/git-am cannot be used without a working tree.

Please help me out

Thanks in advance.

0 Likes
1 Solution
ArvindS_76
Employee

OpenOCD is not supported by WICED-Smart SDK yet (we plan to support this sometime in the future). The SDK comes will all other tools you need to build and run applications on the BCM20732 platform, so you don't have to build any of these from source. I would also recommend that you download and use SDK 1.1.0 which is the latest release.

View solution in original post

1 Reply
ArvindS_76
Employee

OpenOCD is not supported by WICED-Smart SDK yet (we plan to support this sometime in the future). The SDK comes will all other tools you need to build and run applications on the BCM20732 platform, so you don't have to build any of these from source. I would also recommend that you download and use SDK 1.1.0 which is the latest release.

View solution in original post