cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Hi,

I have a fresh install of the Wiced Smart SDK version 2.2.2 but I am unable to launch the IDE after the install and get a Framework Event error: Is this related to eclipse version bundled with the SDK being too old and not work with the latest version of java installed on my machine., Anyhow how do i fix it.

!SESSION 2018-08-28 23:50:45.237 -----------------------------------------------

eclipse.buildId=M20130204-1200

java.version=10.0.2

java.vendor=Oracle Corporation

BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US

Framework arguments:  -product org.eclipse.epp.package.cpp.product -keyring /Users/akshitdayal/.eclipse_keyring -showlocation

Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.cpp.product -keyring /Users/akshitdayal/.eclipse_keyring -showlocation

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2018-08-28 23:50:50.670

!MESSAGE FrameworkEvent ERROR

!STACK 0

org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.0.301.v20120914-163612 [234]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4

  at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)

  at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)

  at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)

  at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)

  at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)

  at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)

  at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

  at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2018-08-28 23:50:50.679

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.v20120914-163612.jar was not resolved.

!ENTRY org.eclipse.osgi 2 0 2018-08-28 23:50:50.696

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.696

!MESSAGE Bundle reference:file:plugins/org.apache.xmlrpc_3.0.0.v20100427-1100.jar was not resolved.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.696

!MESSAGE Missing imported package javax.xml.namespace_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.696

!MESSAGE Missing imported package org.apache.ws.commons.serialize_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.696

!MESSAGE Missing imported package org.apache.ws.commons.util_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package javax.xml.bind_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package javax.xml.parsers_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.apache.commons.logging_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.xml.sax_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.apache.commons.httpclient.params_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.apache.commons.httpclient_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.apache.commons.httpclient.auth_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.apache.commons.httpclient.methods_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.697

!MESSAGE Missing imported package org.w3c.dom_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.698

!MESSAGE Bundle reference:file:plugins/com.broadcom.wiced.doc_1.2.0/ was not resolved.

!SUBENTRY 2 com.broadcom.wiced.doc 2 0 2018-08-28 23:50:50.698

!MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_0.0.0.

!SUBENTRY 2 com.broadcom.wiced.doc 2 0 2018-08-28 23:50:50.698

!MESSAGE Missing required bundle org.eclipse.core.runtime_2.1.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.698

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.v20120914-163612.jar was not resolved.

!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2018-08-28 23:50:50.698

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.1))(&(osgi.ee=JavaSE)(version=1.4)))".

!ENTRY org.eclipse.osgi 2 0 2018-08-28 23:50:50.702

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.702

!MESSAGE Bundle org.apache.xmlrpc_3.0.0.v20100427-1100 [17] was not resolved.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.702

!MESSAGE Missing imported package javax.xml.bind_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package javax.xml.namespace_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package javax.xml.parsers_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.commons.httpclient_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.commons.httpclient.auth_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.commons.httpclient.methods_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.commons.httpclient.params_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.commons.logging_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.ws.commons.serialize_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.apache.ws.commons.util_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.w3c.dom_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.xml.sax_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.

!SUBENTRY 2 org.apache.xmlrpc 2 0 2018-08-28 23:50:50.703

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=JavaSE)(version=1.4))(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.704

!MESSAGE Bundle com.broadcom.wiced.doc_1.2.0 [233] was not resolved.

!SUBENTRY 2 com.broadcom.wiced.doc 2 0 2018-08-28 23:50:50.704

!MESSAGE Missing required bundle org.eclipse.core.runtime_2.1.0.

!SUBENTRY 2 com.broadcom.wiced.doc 2 0 2018-08-28 23:50:50.704

!MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-08-28 23:50:50.704

!MESSAGE Bundle org.eclipse.equinox.simpleconfigurator_1.0.301.v20120914-163612 [234] was not resolved.

!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2018-08-28 23:50:50.704

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.1))(&(osgi.ee=JavaSE)(version=1.4)))".

!ENTRY org.eclipse.osgi 4 0 2018-08-28 23:50:50.708

!MESSAGE Application error

!STACK 1

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)

  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)

  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)

  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

  at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

  at java.base/java.lang.reflect.Method.invoke(Method.java:564)

  at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)

  at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)

  at org.eclipse.equinox.launcher.Main.run(Main.java:1438)

0 Likes
Reply
1 Solution
Moderator
Moderator

Hi,


Wiced eclipse does not work with java version 9.0 or higher. So please downgrade the java version and try.

Thanks & Regards,

Anjana

View solution in original post

3 Replies
Moderator
Moderator

Hi,

Could you please confirm you have followed the steps mentioned here: WICED-Smart-SDK-2.2.2-IDE-Installer.zip

The WICED SMART SDK utilizes a 32-bit version of an Eclipse based IDE which requires a 32-bit version of JRE to be installed. If you have the 64-bit JRE installed you will need to install the 32-bit version as well. The JRE is designed to allow both 32 and 64 bit variants to be installed on the same system.

(WICED SMART FAQ )

Thanks & Regards,
Anjana

Anonymous
Not applicable

Yes that the first thing i looked for before postibg rhe question here. I don't see a 32b Jdk or JRE for macos. 32b is only available for Windows os

0 Likes
Reply
Moderator
Moderator

Hi,


Wiced eclipse does not work with java version 9.0 or higher. So please downgrade the java version and try.

Thanks & Regards,

Anjana

View solution in original post