Announcements
IMPORTANT: Cypress Developer Community is transitioning on October 20th. To learn more and be prepared for this change, check out our latest announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

===

SDK: 2.1.

Tag: 920737.

app: OTA hello-sensor.
OTA firmware size ~ 18KB.

===

We use WsOtaUpgrade to download a image size bigger than example size(9KB).
Test 5 times but only 2 times ok and 3 times failed during downloading process.
I try to add trace and find as attached snapshot (hello_sensor_OTA_lower_layer_Queue.jpg) ,

@$*#04FF0EF7009201010000E5750405FF0000@$*#04FF0EF7009201010000E5750405FF0000@$*#04FF0EF7009201010000E5750405FF0000Write

NV in

NV out 0.

@$*#04FF0EF7009201010000E5750405FF0000@$*#04FF0EF7009201010000E5750405FF0000@$*#04FF0EF7009201010000E5750405FF0000Write

NV in

Write NV out 0.

@$*#04FF0EF7009201010000E5750405FF0000

[..... NO RESPONSE]

[PC:] hello_sensor_timeout:81   [ lower-layer seems alive cause timer thread is alive]

it seems when downloading a big file, when lower-layer of BLE pass the file segment
to app layer for storage which is ok to write to NV but owing to storage speed (may be a little slow)
and owing to PC site's transmission (maybe a little faster), the lower-layer file segment transfer
will be suspended or failed when continue transfer.


I try to do some way for this problem

- to kill timer before transfer start.

- to  update connection request slower like  lel2cap_sendConnParamUpdateReq(8, 15, 0, 900);

still have same problem found.

Is there any help for this issue? ( Try to make a delay in lower-layer or something or to increase
larger buffer in lower-layer Rx...something like this.)

0 Likes
1 Solution
VictorZ_46
Employee

I am not sure if it is the problem, but we identified an issue in the Windows driver USB selective suspend processing.  The fix is on the way, but to work around the issue, try to display the properties of the device Bluetooth Radio device in the Device Manager.  In the Power Management tab remove the check on the "Allow the computer to turn off this device to save power" box.

View solution in original post

7 Replies