cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

===

SDK: 2.2.

Tag: 920737.

app: hello-sensor.

OTA firmware size ~ 28KB.

Phone OS: Android ver >= 4.4

===

Problem: By using Android phone to disconnect the link with sensor slave site,
the link is not disconnected but if using iOS phone, the link can be disconnected.


Condition:

- SDK2.2 encr_required = (SECURITY_ENABLED | SECURITY_REQUEST),

- OOB_PAIRING and PASSKEY_PAIRING are not defined and disabled.

Desired result:

- Both Android and iOS phones to disconnect the link should be ok.

0 Likes
Reply
1 Solution
Employee

I think HTC One M8 and E8 are also based on 4.4.2. It may be a good idea to test it out against these phones.

I have asked Frank to get in touch with you.

View solution in original post

0 Likes
Reply
14 Replies
Employee

i have a htc one e8 running with android 4.4.2. i was not able to reproduce the issue with my tag3. and i can simply disconnect the device by 'unpairing" it in the bt settings page. how do you unpair your tag from the phone?

0 Likes
Reply
Anonymous
Not applicable

Hi, boont,

I am confused with the actions of un-pair and disconnection.

Action: enable encr_required.
use our APP to connect with slave sensor and then disconnect it -

Iphone5: link is disconnected and no need to un-pair it.

HTC D816x: link is not disconnected and use un-pair in setting menu, it can be disconnected.


so originally, what correct behavior I think is,

if disable encr_required,

both Iphone and Android phone connection can be set by disconnection button of phones.

if enable encr_required,

both Iphone and Android phone connection is still alive when pushing disconnection button of APP on phones,

but link can be disconnected in setting menu by un-pairing.


However, what i meet is if enable encr_required,

Iphone link can be disconnected by APP button without un-pair from setting menu.

So this is why I feel strange why in Android phone behavior, it cannot be disconnected directly as

Iphone did.



0 Likes
Reply
Employee

On the bt settings page, i press-and-hold the device_name on the screen, it will prompt me to disconnect the link. I have to go furthur with one more step if I want to unpair. Do you see this on your HTC?

0 Likes
Reply
Anonymous
Not applicable

Hi, Boont,

Yes, my tested Android phone has same result as urs.

When APP button trigger disconnection, it is not real action. I have
to select BT setting page to select my device and un-pair the link.
This is  enabled pair mechanism.

However, with iOS phone (my tested phone is Iphone5), when I choose
APP disconnection button, the link is indeed disconnected without selecting
pair/unpair setting menu. So both OS-handset have different operation behavior.
Any help about it? TKS.

0 Likes
Reply
Employee

I used a S4 with a WICED Smart Explorer app and was able to connect with my tag3. I can do a disconnect. And when I refer to my BT settings, it showed "Hello" with the status "Paired". The link is disconnected but both devices still retained pairing information.

I can't comment on your APP and I have asked Frank (Avnet) to get in touch with you on this issue.

0 Likes
Reply
Anonymous
Not applicable

Hi, Boont,

I use Infocus M810 with Android system V4.4.2.

I find HTC handset is ok but InfoCus will be failed when using free APP
disconnection button. Only if does user try to select BT menu and re-activate BT device
of handset can make connection release.


Please check the log. U can find "pairing failed" from log after disabling handset BT device.

It seems, when free APP disconnection action start before BT device disabling, something

wrong at lower-layer of handset in L1.


0 Likes
Reply
Anonymous
Not applicable

More logs of test.

0 Likes
Reply
Employee

This could be an equipment interoperability issue among the myriad of mobile phones, which I am unable to dwell furthur. Frank will work onsite with you on this issue.

0 Likes
Reply
Anonymous
Not applicable

Hello Leo,

Can you try to disconnect any proximity device from your Android phone?

Thanks

JT

0 Likes
Reply
Anonymous
Not applicable

Hi, all,

I just use SDK 2.2 of hello-sensor instead of our product firmware, InfoCus still gets the failure result.
Wonder that when connection link is just established, any category or capability info of handset
sent to slave site? Does BCM-737 try other speedy handset for this issue? It seems handset-specific
having this problem or timing issue. Any timing configuration to adjust in lower-layer?

0 Likes
Reply
Anonymous
Not applicable

Hi, JT/Boont,

Attach the hello-sensor log for ur investigation.

In log,

First section is successfully pairing and disconnection after handset release the link.
U can see slave site broadcast as ADV xxx. (handset: HTC D816.)

And the last section, after connection link is established; when handset release the link,

I didnt see any connection release and no ADV is broadcast which means the link is still there. (handset: InFocus M810)

0 Likes
Reply
Employee

Hello sensor is our golden reference. What is the OS and version of Infocus M810? Is it possible to test it against another Infocus handset? Or Test it against another brand with the same OS and version as M810?

0 Likes
Reply
Anonymous
Not applicable

Hi, Boont,

It's Android V4.4.2 and InFocus is our product DQA dept. bench-mark so
they focus on issues by those handsets.
BTW, any signal capture help from Frank? TKS.

0 Likes
Reply
Employee

I think HTC One M8 and E8 are also based on 4.4.2. It may be a good idea to test it out against these phones.

I have asked Frank to get in touch with you.

View solution in original post

0 Likes
Reply