cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

Hi,

    I have been trying to get the passkey operation to work, and have had a look at the various discussions and have a very simple question.

As the passkey operation is not working correctly, will connect to anything even if the passkeys do not match, when will this be fixed so that it will operate correctly ?

Thanks

0 Likes
Reply
1 Solution
Employee

Could you please explain what exactly is the problem.  I defined passkey paring at the top of the hello_sensor

#define PASSKEY_PAIRING

#ifdef PASSKEY_PAIRING

//passkey=123456

const UINT8 passKey[LESMP_MAX_KEY_SIZE] = {0x40, 0xE2, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00};

When I attempted the connection from the LightBlue on iPhone it prompted for the passkey.  If I enter wrong value I can see the trace

13:13:33 - hello_sample, bond result 00 smpinfo addr type:0 emconninfo type:1

If I enter correct value (123456) the trace is

13:14:32 - hello_sample, bond result 03 smpinfo addr type:0 emconninfo type:1

The LESMP_PAIRING_RESULT_BONDED is defined as 3.

(disclaimer.  I am using beta 2.2 version, but I am pretty sure it should work the same in 2.1.1)

lloyd.mcintyre vauser eyan vsesto fwegher danyryu

View solution in original post

0 Likes
Reply
11 Replies
Moderator
Moderator

Confirming that there is an issue with existing passkey functionality and am confirming with the developers that this will be resolved in SDK 2.2

victorz arvinds vik86 j.t

0 Likes
Reply
Anonymous
Not applicable

Please can you provide a detailed timeline when this major bug is going to be fixed, ie, when is SDK 2.2 going to be launched?

Is there no way to offer a patch to this issue without waiting for a complete overhaul of the SDK?

0 Likes
Reply
Moderator
Moderator

Unfortunately, I do not have a detailed timeline to provide. I assure you that I am trying to work with the business unit within Broadcom to escalate to see if this will eventually be resolved.

pnorbury arvinds ahunter victorz khanm j.t

0 Likes
Reply
Moderator
Moderator

We did some testing today internally with an early release of SDK 2.2 and it appears that Passkey is working properly when using the Hello_Sensor application.  This does not seem to be the case on the current SDK, 2.1.1

SDK 2.2 should be released with the next week or two.

vauser pnorbury michel.siohan

0 Likes
Reply
Anonymous
Not applicable

Thanks for this quick answer

Best regards

Michel

0 Likes
Reply
Anonymous
Not applicable

Thanks for the reply, will look forward to SDK 2.2 next week.

LLoyd

0 Likes
Reply
Anonymous
Not applicable

Hi...have you any idea of the release date of the SDK 2.2 ?......it was supposed to one - two weeks and we are now in week three ?

Thanks

0 Likes
Reply
Moderator
Moderator

We experienced a few setbacks based on personnel changes internally, but SDK 2.2 is in SVT now and we are hoping for a release early next week (possibly Friday, but I don't want to promise since I have no control).

0 Likes
Reply
Moderator
Moderator

lloyd.mcintyre

I wanted to let you know that SDK 2.2 was released today and is available in the WICED Smart Documents & Downloads section.

It has some patches applied which may help with this issue.

0 Likes
Reply
Moderator
Moderator

Can you describe how you had intended to use the passkey function within the application. Once understood, perhaps one of the developers can offer a work around.

vauser victorz

0 Likes
Reply
Employee

Could you please explain what exactly is the problem.  I defined passkey paring at the top of the hello_sensor

#define PASSKEY_PAIRING

#ifdef PASSKEY_PAIRING

//passkey=123456

const UINT8 passKey[LESMP_MAX_KEY_SIZE] = {0x40, 0xE2, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00};

When I attempted the connection from the LightBlue on iPhone it prompted for the passkey.  If I enter wrong value I can see the trace

13:13:33 - hello_sample, bond result 00 smpinfo addr type:0 emconninfo type:1

If I enter correct value (123456) the trace is

13:14:32 - hello_sample, bond result 03 smpinfo addr type:0 emconninfo type:1

The LESMP_PAIRING_RESULT_BONDED is defined as 3.

(disclaimer.  I am using beta 2.2 version, but I am pretty sure it should work the same in 2.1.1)

lloyd.mcintyre vauser eyan vsesto fwegher danyryu

View solution in original post

0 Likes
Reply