cancel
Showing results for 
Search instead for 
Did you mean: 

WICED Smart Bluetooth

Anonymous
Not applicable

I cannot pair my BLE device (BCM20736S) with Samsung Grand Prime smartphone driven by Android v5.1.1. (result: smp_bond_result = 1, timeout). The device is seen as bonded on Android side, but not on Broadcom side.

The pairing is successful with the same smartphone but driven by Android v5.0.2., or Samsung Galaxy S4 with Android v4.4.2.

Did someone encountered this issue, or have some any idea ?

0 Likes
1 Solution
BoonT_56
Employee

I can't say for sure what is the issue. It could likely be an one-off incident of SW incompatibility. The fact that your product works for other Android versions as well as other SM-G53X models speaks for itself.

View solution in original post

0 Likes
6 Replies
BoonT_56
Employee

My android phone has only been updated to v5.0.2 and so I can't try the above scenario. Can you go to Bluetooth settings and "delete" or "forget" your BLE device and repeat the whole pairing process?

0 Likes
BoonT_56
Employee

I updated my phone to the latest android v6.0.1. I used it to pair with a Hello_app running on a tag3. No issue at all. yrt

0 Likes
Anonymous
Not applicable

I have already tested with different brand of smartphones and different versions of Android from 4.0.3 to 6.0.1 wit success. The issue appears only on this smartphone with this version. So I just demanded if someone have already faced this issue with this version (5.1.1).

In fact the behavior is strange, because the smartphone consider that it is connected, and begin to send request (writes the characteristics) and the Broadcom answers with sending indications (we simulate a SPP profile on BLE). This continues during 30s, until a timeout fires and we have the message "smp_bond_result = 1".

0 Likes
Anonymous
Not applicable

I cannot forget the device because the pairing procedure does not end, and the device does not appear int he paired devices list.

When I said "The device is seen as bonded on Android side", I wanted to say that the Android Studio Bluetooth log messages show that the status of the device goes to "bonded" but goes down to disconnected after 30s.

0 Likes
Anonymous
Not applicable

I tested  the phone (Samsung Grand Prime model SM-G531F) with the Hello sensor application. I cannot bond the phone with the Bluetooth settings page, but it works with the other Samsung Grand Prime (model SM-G530FZ)...

Do you think there is something special with this phone model, or is this phone out of order ?

0 Likes
BoonT_56
Employee

I can't say for sure what is the issue. It could likely be an one-off incident of SW incompatibility. The fact that your product works for other Android versions as well as other SM-G53X models speaks for itself.

View solution in original post

0 Likes